v3 blocking outlook express email [Merged Threads]

I have just loaded v3 firewall, and all seems well, apart from outlook express. No matter what I do (the ports are apparently ok), I cannot send or receive messages on my email. Any suggestions appreciated.

In V3 settings for application rules in network security policy what are your settings for Outlook express?

If you can it would help if you can post a screenshot.


I tried the new version 3 last night but for the life of me couldn’t get it to work to allow my email to come thru.

I tried every setting I could but eventually gave up !!! (:AGY)

The previous version 2.4 was working fine !!!

Can someone help please…is anyone else having the same problem.

By the way I am using Microsoft Outlook/ XP home with all updates

Thanks !!!

I’m having the same experience with Mozilla Thunderbird. It worked fine in version 2; it can neither send nor receive after this morning’s update to version 3, even though it’s a trusted app.

Exactly the same problem with Outlook 2007 and exchange server. I have opened a topic just a couple of hours ago “OUTLOOK 2007 can’t connect on Exchange Server”. It seems this issue is extended to other email clients, also. POPFile succesfully reads the email on the server.
Any help?

I’m anxious to get this resolved, but it’s back to 2.4 for me for in the meantime.

I am using Outlook 2003 and can’t send e-mail. Every time I attempt to send I get a yellow popup saying “Outlook could not be recognized and is about to connect to the internet. If it is one of your every day applications you can allow this request.” It’s already checked to remember and I click OK, but 10 seconds later I get another one, and another one… In the middle of all this Outlook puts up an error message that it can’t send. Yes I clicked “treat this as” on the pop up and clicked trusted in drop down menu.
Under Firewall>Advanced>Network Security Policy>rules It says:
C:\program~micros~3\office11\outlook.exe Custom
Allow IP out from IP any to IP any where protocol is any

I have CFP 3 set for a simple firewall with D+ disabled. The only thing I clicked was in Common Tasks,
Stealth Ports Wizard. I click option 3 - Block all incoming connections - stealth my ports to everyone (for average user). Then it says something like “Setting is made”. However, Every time I check back to see my setting it’s back to option 1 which says “Define a Trusted Network - Stealth my ports to everyone else.” Is the Stealth Ports Wizard doing this because I’m set up for a simple firewall and the Wizard is smarter than I am? Or what? Thanks in advance for any help.

I have exited out of v3 and just used xp firewall. Still not working…see below

“Your server has unexpectedly terminated the connection. Possible causes for this include server problems, network problems, or a long period of inactivity. Account: ‘pop.karoo.co.uk (2)’, Server: ‘pop.karoo.co.uk’, Protocol: POP3, Port: 110, Secure(SSL): No, Erro
r Number: 0x800CCC0F” PS - How can I do a screen shot? I’m a bit thick!

First thing to do is to look at the Firewall Log and see where blocking is a actually occuring within Comodo firewall. And look at Firewall Security Practices and see what rules you have for Outlook Express. Post them and maybe more help.

Hello Guys,

Can you please show the following:

1 - You COMODO Firewall Logs (Firewall->Common Tasks->View Firewall Events
2 - Screenshot of your “Network Security Policy” (Firewall->Advanced->Network Security Policy

  • Can you also tell us about your internet connection i.e. How do you connect to the Internet? Dialup?ADSL?
  • Can you please tell us what sort of applications you have installed in your PC?

Does the following workaround fix the problem ?:

Disable Protocol Analysis by unselecting “Firewall->Advanced->Attack Detection Settings->Miscellaneous->Do Protocol Analysis”


Thanks for your response, but it is obvious this is an across the board outgoing e-mail problem involving Outlook express and Outlook. Listing how we log on to the internet and what apps we use won’t do anything. Everything works great in v2.4 and no outgoing in v3 makes where the problem is obvious. We have to find where v3 is ■■■■■■■ up and make a fix. For details please see my original post in this thread back a ways in reply #6. :frowning:

Unchecking Do Protocol Analysis doesn’t fix it.

Hi just downloaded the new version which sprung up on my computer this morning, but now it won’t let me access outlook express.
When I removed it I could then access outlook, but on reinstalling it - it has blocked it again.

What is different, as I havent’ changed any settings and on looking outlook seems to be allowed.

Hi, Join the rest of us in the post below entitled “Outlook Express” :-\

i installed comodo firewall and microsoft outlook wont work now.
any tips where i may look to find out why i am getting blocked?
it worked fine before i did this upgrade last night.
nothing else to report. it seems to run great.

thanks for any help,

Please help.
V3 not allowing me to access or send email via outlook express. Help sections are no help. Hotmail and googlemail and comcastmail work no problem. It’s getting comcast (my primary email source) to download into OE is the problem. Also cannot send out through OE.
Right now the only way I can use OE is if I disconnect v3 altogether, reboot, get my email sorted, answer the email and then run v3. Luckily, spysweeper is checking email.
I’m considering going back to v2, which worked fine…TIA…Ian

try this temp fix pls…

Hi Guys,

More than a million PCs is using CFP 3right now and the weird bugs/problems are posted in the help board.

2 of these problems seem to be recurring. Here are the temporary fixes until we update the executables:

1 - cmdagent.exe 100% CPU consumption:

This has been verified and fixed with the upcoming update. It is related to patched uxtheme.dll.
However, until the updates are issued the temporary fix is disabling the registry protection :

  • Defense±>Advanced->Defense+ Settings->Monitor Settings
  • Uncheck “Protected Registry Keys”
  • Press Apply and restart

2 - System Slowdown issue :
It is related to the load on comodo lookup servers.

Online file lookup must be disabled

  • Miscellaneous->Settings->Update
  • Uncheck “Automatically perform an online lookup for the unrecognized files” option
  • Press Apply button

Both 1 & 2 should solve the most of the problems.

3 - Email client problems

  • Firewall->Tasks->Stealth Ports Wizard
  • Select “Alert me to incoming connections”

Then Protocol analysis should be disabled.

  • Firewall->Advanced->Attack Detection Settings->Miscellanous
  • Uncheck “Do protocol analysis” option

Thank you all for the cooperation,



I installed comodo firewall V3 and it detects a private network (using ethernet connection, this connection is a professional one). All applications works. I want to check and send email from my home connection and it doen’t work correctly. At home, I use a WIFI connection. I add a new network for the wifi connection using the MAC address because it doesn’t recognize the wifi connection. Now I can receive email but I can’t send email. The error message from outlook spoke about it cannot join the pop mail server, I try to ping the pop adress but it doesn’t work.

Is it a problem of configuration of the firewall? Could help me to solve this problem.


Are you using gmail or encrypted email through your ISP? Comodo left port 995 off the port list that supports their email client rules, so won’t work if you try to use that predefined policy. If you are using gmail and Thunderbird, also need to add port 587.

No I’m using Microsoft Office Outlook 2003. Before the installation of comodo firewall V3, I was using the V2 and no problems.