uTorrent Port Forwarding

How do I do that? I added a rule in version 2.4 for utorrent but I don’t know with this one, partly because I am not good with firewall rules etc.

Also if you can would you mind including information for port forwarding for mIRC and Limewire? thanks

The general rule for any p2p application is:

  1. Allow outgoing TCP/UDP connections to any destination hosts, any destination ports.

  2. Allow incoming TCP connections to the destination port that matches the one specified in your applications settings (I think they’re randomly selected from some range upon installation). Check the Options - Preferences - Connection to see what TCP port your uTorrent uses.

  3. Same as above for UDP. Allow incoming UDP connections to the destination port that your application specifies. It may be the same port number as with TCP (I think this is the case with uTorrent), or a different port number (e.g. eMule allows different port numbers for TCP and UDP).

The important things is: you should allow that both in Global Rules AND in Applications Rules for your application’s executable.

The 5 rule set posted by Pandalouk (sp)? …


How to configure Comodo firewall 3 for µTorrent.

  1. Go to : Firewall → Advanced → Attack Detection Settings → Miscellanous and disable Do Protocol analysis

  2. Go to : Firewall → Advanced → Predifined Firewall Policies and select Add…

Give a name at the new Predifined Policy for example: µTorrent

Add the following rules:

Rule 1

Action = Allow
Protocol = TCP or UDP
Direction = In
Description = Rule for incoming TCP and UDP connections
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = the port of utorrent

Rule 2

Action = Allow
Protocol = TCP
Direction = Out
Description = Rule for outgoing TCP connections
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = A port range = (start port = 1025 / end port = 65535)

Rule 3

Action = Allow
Protocol = UDP
Direction = Out
Description = Rule for outgoing UDP connections
Source Address = Any
Destination Address = Any
Source port = the port of utorrent
Destination port = A port range = (start port = 1025 / end port = 65535)

Rule 4

Action = Allow
Protocol = TCP
Direction = Out
Description = Rule for HTTP requests
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = 80

Rule 5

Action = Block (enable Log as a firewall event if this rule is fired)
Protocol = IP
Direction = In/OUT
Description = Block and Log All Unmatching Requests
Source Address = Any
Destination Address = Any
IP Details = Any

  1. Start utorrent. When Comodo asks you with a popup, choose ‘Treat this application as’ select utorrent and enable Remember my answer.

If you have connectivity problems:
Go at Firewall → Common Tasks → Stealth ports wizard and select
Alert me to incoming connections- stealth my ports on a per-case basis

I have followed those instructions but I still get a orange triangle which then after about 5mins it turns into a red circle with an exclamation mark in the middle. What can i do to stop this?

Holden Mad

The 5 rule set doesn’t include a Global Rule for incoming TCP/UDP connections to your uTorrent port - have you added a global rule as well? (You may or may not need to set up a global rule, depending on how you have CPF set up).
Also check that your router also has it’s ports forwarded correctly - you can use uTorrents built in port checker to make sure you are set up correctly.
Also make sure you are not set up to use a random port in uTorrent - set one yourself + make sure UPnP is turned off!
Oh and one last thing - have you set up a static IP for your computer? If not you may have to redo everthing after a reboot!

OK. Thanks i will try that and report back. How come it didnt take this much work with V2? I think i may and up just going back to V2.

Holden Mad

Don’t get confused by all the new stuff… v3 and v2 aren’t totally apart… just some layout and verbiage changes are confusing you.

Whatever you did in v2 to allow uTorrent in “Network rules”, is the same core addition that you need to add in v3 to “Global rules”. Realistically this is the only critical part.

You could run uTorrent and answer the firewall popups and train it on the fly… or you could use one of the new features to define a common rule set that you can use to apply to any other application (like what was posted above… creating a rule set). A fantastic new feature, but not uber important to getting your uTorrent up and running like you are expecting.

Just remember that Global rules in v3 = Network rules in V2, and you should be fine.

You can always learn the fancy stuff later (:WIN)

P.S. a couple other settings I might choose to keep things running generally as expected…

  1. set firewall to “Custom Policy”
  2. set Defense+ to “Train with Safe mode”

I tried the stuff that’s written in this post. It didn’t help. I still had tons of blocks to the port I had opened in Comodo. It was mostly TCP but a also a few UDP blocks.
But it seems the FW didn’t block everything as I could download/upload as normal. Maybe it blocked a few peers randomly or something…

The most strange thing was that even with CFP not running it seemed to keep blocking. Utorrent said the port was closed. As soon as I uninstalled CFP the port was open and the icon became green again.
Back to 2.4 I guess.

Then I would suspect any Global rules you added were probably below the block rule… therefore never reached… the block rule need to be on the bottom.

Downloading and uploading are all events that occur FROM you PC… hence OUTBOUND communications… so no inbound rules would interfere with those communications.

Maybe so, I can’t be bothered to try again. I haven’t even installed 2.4 again. How’s 3.0 an improvement if it requires 6 rules to make 1 program function correctly when it before only required 1 rule…

You should reread my reply 4 posts up… one “global rule” to replace the “old network rule”

Have you done this step ?
It should be fine if your rules is set as above.

I am behind a router, so i simply put UTorrent as trusted application and didn’t even bother to make specific rules. Works like a charm.

If you don’t have a router, you should consider buying one. It solves many problems.

Ok, just for fun, i made specific UTorrent rules, they work fine with UTorren 1610.

Under Predefined Network Policies, make a new Utorrent Rule.

Then rules:

  1. Allow TCP and UDP IN
    The only setting you must change is destination port (you put the port number your UTorrent uses).

  2. Allow TCP and UDP out
    Any in all tabs for both protocols.

3)Allow ICMP IN and OUT
Any in all fields (not sure if it serves, but with Emule if they can ping you, you get better results, so i put it there too).

  1. Allow UDP from Router IN (In case you have a router)
    In my case i did allow UDP in from “IP Mask” - , any port.

I added this last one, because with only the first 3, i still got an inbound UDP request from my router’s IP to port 1900 if i remember correctly. Your router should be safe anyway, so why restrain ports…

After this, i have full green icon and torrenting is fine.

I hope this will help you.

I had problems until I created a Global Rule. In that rule I allow UDP/TCP out and enter 2 ports. Port 53 and port 80 (I named the rule DNS). It fixed the problem of not being able to find the tracker.

As for uTorrent rules I used the set that JolietJake posted (Thanks BTW :slight_smile: ). Working like a charm.

I’ve noticed that some people allow their torrent client to use what ever port it wants. When they use ‘privileged ports’ CFP blocks them because I don’t allow uTorrent to access those ports.


If you have a router, you'll need to configure it for port forwarding:


  1. Choose your router model (if it’s not in the list, choose one from the same company)
  2. Select the software (in this case, uTorrent)
  3. Now follow the steps in the guide


Although I was able to use uTorrent and downloaded successfully (using pandlouk’s rules) , the port forwarding test on the uTorrent speed guide said unsuccessful until I used the port forward guide.



i have discovered it myself

open comodo → FIREWALL

in firewall taks, click in advanced and then - “network security policy”

edit rule to utorrent like you did in version 2.4

bye ;D

The steps not included in the 5 steps posted by JolietJake are:

Go to Firewall–>Advanced–>Network Security Policy–>Application Rules

A. select (highlight) ‘c:\Program Files\utorrent\utorrent.exe’ or wherever utorrent
is located
B. Edit–>Use Custom Policy–>select ‘utorrent’ (or whatever you named the
predefined policy in the beginning)

Also remember -

  1. make sure ip address is static
  2. make sure router is set up correctly (go to http://www.portforward.com for help)
  3. make sure ‘Enable PnP port mapping’ option is NOT selected in utorrent

Works for Me! …And thanks to all for extremely useful help!! (:CLP)