Uses 100% resources on install, stops on scan [Resolved]

I just unistalled Kerio and am trying to install Comodo 3 on my Win XP-2 system. I note that as it gets to the scan, it locks up on the nvidia stuff. It is using 100% resources. I had to do a hard reboot. I looked in the installed programs and did not find Comodo, and so I attempted to reinstall. Same problems.

I am running the install while not hooked up to the Internet. I assume that’s okay. It’s hard for me to believe that a firewall installation requires one to be exposed to the internet during the half-hour or so that the installation takes. Am I wrong to assume this?



Hi Alan, welcome to the forums.

Firstly, CFPs Scan is not a mandatory part of the installation (although it is desirable). Once the Scan is offered, that means the installation is completed. In short, you can skip it if it’s causing problems. The Scan can be run manually, at any time, from CPFs Defense+ tab.

The Scan problem: Is it always sticking on the same file? What are the Nvidia files in question? The 100% resources might be due to CFPs Scan unpacking an extremely large packed file (ZIPs, RARs, etc…) or lots of them. In addition, you should be able kill the Scan (CFPCONFG.EXE) from the Task Manager without any problems, rather than rebooting… unless your system is non-responsive?

Oops… missed one your questions: No, you should not be connected to the Internet during the installation of CFP. Mainly, because if you’re installing CFP… then you don’t have a Firewall (excluding Windows Firewall) at that particular moment & as you indicated, that leaves you rather exposed.

Thanks for the reply, Kail.

It did not give me a choice, as I recall, about running the initial scan. When it did lock up, I attempted to end the process through the task manager, but to no avail. As of right now, I seem not to have internet access on that computer. I noticed the Comodo program folder on drive C under C:\Program Files, but there is nothing on the start menu and nothing on the Add/Remove programs from the settings menu. So apparently, I have a faulty install, no internet access, and I feel stuck. I have a feeling this is going to be a long night.

I did not mention this before, but after the second attempt to reboot, I had to reactivate Windows. Because I had no internet access, I had to call Microsoft, a very irritating process.

This is a dual boot system, with Linux on the other partition, and so I am going to see if the cable modem works from there. If it does, then I’ll know it’s a software problem.

I’ll check back here in a half hour or so. I’m glad someone’s there.



PS: I booted into Ubuntu on that machine and cable modem worked fine. So it’s definitely something wrong with my Windows installation



Hi Alan,

I am glad you worked out the problem is on your end, and not CFP 3’s. Are you going to Reformat? If so, After Reformatting install CFP3 and let us know what happens.


Woah there hoss!

I haven’t ruled out anything yet. It’s best not to jump to conclusions.

Here are the facts: I subscribe to Windows Secrets newsletter, and they said that my former firewall (Kerio) was not reliable, according to a survey they have confidence in. They recommended several, including Comodo. I noticed on Castlecops that several were using Comodo.

Before I uninstalled Kerio and installed Comodo, I was not having the above-mentioned problems. It’s way too early to pin the blame somewhere, but right now, I am in safe mode on my other machine and weeding out all the references to Comodo I can find, because I can’t get rid of some of them in regular mode.

If you were me, and based on the experiences I outlined above, what would you think? Please give reasons.



PS: As an addendum to the above, it appears that there are a bunch of keys that can’t be removed from the registry even in safe mode.

I wonder what gives? This does not look good to me. What do you think?



More of an update:

I downloaded Glary utilities and Winsock Fix with another computer and ran them on the malfunctioning computer. It seems that the home computer is running a bit more like it did before Comodo, but still no connection to the internet. At this point, I suspect that Comodo may well have done in my internet connection in a very fundamental way. I hope I don’t have to reinstall Windows.

Have others reported similar problems? Any clues from anyone on how I might fix this?



Hi Alan,

One thing you can try in getting your internet connection back is to reset the Windows sockets. This is done by running the following command (minus the quotes) from a command line;

“netsh winsock reset”.

After running this command, reboot (purely to ensure that the reset state is used) and see if you can connect to the internet again.

I’ve re-read your original post and would like clarification on two points.

What do you mean, exactly, by “the scan”? If it is the malware scan, this is purely optional, as pointed out by kail, and must be selected by the user at the end of the installation process. There have been no other reports of it doing it’s thing of its own volition.

When you referred to “nvidia”, are you referring solely to nvidia graphic drivers and utilities, or does your motherboard use an nvidia chipset, which adds several nvidia components to the windows installation?

Also, what other security software, if any, are you running?

Ewen :slight_smile:

Hi Ewin,

You wrote:

Yes, I meant the malware scan. I probably am misremembering, but I do not recall seeing a way not to run the scan.

[]NVIDIA NForce MCP2 IDE Controller
]NVIDIA GeForce4 MX 440 with AGP8X [Display adapter]
[*]NVIDIA nForce MCP Networking Adapter

]Sunbelt Counterspy

That didn’t work either. Bear in mind that I am describing a dual boot computer, and the cable modem, card, etc, work perfectly under Ubuntu, as they did under Windows until I attempted to install Comodo.

I hope I can get my Internet connection back without reinstalling Windows.



Hi again Alan,

Given that you’ve specified that you were in deed referring to the malware scan, the question about the nvidia components sort of becomes irrelevant. In fact, the fact that you still can’t get onto the net renders almost everything else irrelevant.

I have a nasty feeling the internet /network connectivity issue is caused by the aborted CFP installation.

Couple of things to check;

Has CFP been completely uninstalled?
Does your network adaptor appear as enabled in Device Manager?
Did the winsock resetting process complete?
Did you get any error messages when resetting the winsock?

Ewen :slight_smile:

P.S. It’s getting late downunder, so I may not be online for much longer (work beckons tomorrow unfortunately). Hopefully, others will pick up wherever we leave off tonight.

Hi Ewin,

You wrote:

That’s exactly the same feeling I have. It’s also why I responded as I did to 3Xist’s post above.

You also wrote:

As I stated before, CFP never showed up in the Add/Remove dialog in the Control Panel. So yes, the installation was faulty. When I tried to delete registry keys dealing with Comodo, even in safe mode, some of them could not be removed. Tonight, I’m going to try to see what I can do with these instructions. The author says:

I quite agree.

You asked about the winsock error message. When running your command line suggestion, I got nothing. When I run Winsock Fix, I get that standard Windows message about having “little or no connectivity.”

I hope someone can help me be able to fix my internet connection short of having to reinstall Windows. Does anyone have any ideas?



You might want to try reinstalling your NIC driver and then reboot.

Registry keys that can’t be deleted usually can if you right-click on them and then enable Full Control in the permissions.

Thanks for the suggestion, Soyabeaner. Right now, I am working, but I’ll see about it when I knock off work around 11:00 p.m. our time (northwest corner of the United States).

I don’t know about installing or reinstalling the NIC driver, so I’ll have to search for that information. Meanwhile, any links to any articles of interest to me would be greatly appreciated.



Sorry. (:SHY)

  1. Go to Device Manager (one way is right-click My Computer icon then Manage)
  2. Open Network Adapters
  3. Right-click your NIC driver and uninstall
  4. After it’s gone scan for hardware changes by right-clicking any item in there
  5. Reboot just in case

If the reinstallation fails (like you see a yellow exclamation triangle with an ! in the middle next to the driver) then the driver is corrupted. In that case you may need to install the driver from the original location like your PC’s driver discs or the vendor’s website.

[attachment deleted by admin]

Thanks Soyabeaner,

Sounds like good clear advice. I’ll check it out after work.



Well, I seem to have gotten my internet connection back.

Soyabeaner, me parece que estás the lengua español. Muchas gracias para la ayuda. Eres muy amable. La lengua sonorosa y hermosa de Cernvantez es mi otra idioma. What I said was that from his name, I thought perhaps Soyabeaner may be a person of Hispanic heritage. I also speak the beautiful-sounding language of Cervantez. I thanked him for his gracious help.

Taking out Comodo was extremely difficult, even following the directions in the FAQ. One file, C:\WINDOWS\system32\guard32.dll could not be deleted even from the command line in safe mode. I finally had to boot into Ubuntu Linux to get it.

My system is now running well again, and I have reinstalled the Sunbelt Personal Firewall, which admittedly is a bit long in the tooth.

I assume that all who tried to help me here are volunteers and I very much appreciate your readiness and quickness. But if anyone from Comodo monitors this forum, with all due respect, I have a suggestion or two.

Please do not make it so bloody hard to remove the program. No program works for every system configuration. But I have to wonder about a program that crashes on installation, has no really effective uninstallation utility, buries itself so thoroughly into the OS that it takes many hours to weed out and still leaves bits and pieces that cannot be removed even in safe mode, after 5 or 10 hours of nerve-wracking work.



Glad to see my suggestion restored your internet, Alan. lol Soyabeaner is just a made up alias. Soyabean milk is one of my fav drinks, hence, that’s how it originated. Yes, we moderators are volunteer users who have an interest in Comodo products or simply just like helping out.

I believe guard32.dll is the Defense+ (HIPS) driver, which is odd that it was undeletable even in safe mode. It must be really corrupted to the point that it still loads in safe mode.

Unfortunately, the installation didn’t work out for you. CFP is a powerful firewall and HIPS with low-level drivers involved, so it must not be surprising that there was some other software conflict that started this diaster for you. Based on how there was no prompt for you to bypass the optional malware scan process, this was another symptom. If there was any other method that could have made this worked, in case you didn’t already know, it would be to shutdown all programs, particularly security-related ones, duration the installation.

Kerio was the previous firewall I used before CFP, so I would’ve done the same if I was in your situation.

Perhaps in the future you may re-consider CFP. It’s constantly developing along with other products/services. Feel free to roam around this forum if you wish.

(:m*) I’ll close this topic down since your case appears to be resolved in some form or other. If it needs to open, an online mod can be PM’d.