User interface of control center doesn't show up

I have a mini PC “Zotac ZBOX…” which has no preinstalled operating system.

I installed Windows 7 (x64) and the drivers from the enclosed USB flash drive.

Since the installation of the graphics adapter driver, Windows aero works fine. But I percepted issues with Firefox browser and Comodo Internet Security.

I use a theme in Firefox browser but it isn’t displayed. The Firefox UI keeps the same color. The installation of CIS succeeds. But I cannot start the control application. If I execute double click on Comodo’s system tray icon or the linkage in start menu, then nothing happens.

The live scanner seems to work fine. But it’s not possible to show up the user interace.

I think it’s probable that the issue in Firefox and the fatal issue in Comodo are related to each other.

Estimatedly, the main fault is caused by the graphics adapter and its driver software. But finally, I cannot run Comodo conveniently because of an graphics driver issue? This would be unfortunate because then I have to look for another security solution.

Please fix this issue and contact the responsible providers!

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Always reproducable on my machine.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Fresh installation of Windows 7 on a “Zotac ZBOX-CI540NANO-P-BE CI540 NANO PLUS Barebone-PC (Intel Core i5 4210Y, 1,5GHz, 4GB RAM, 64GB SSD, Intel HD 4200, HDMI, Bluetooth, 4x USB 3.0, 2x” (graphics adapter: “Intel HD 4200”)
2: Installation of hardware drivers from the attached Zotac driver DVD (or USB storage) (especially graphics adapter driver: Windows Aearo didn’t work until this was installed)
3: Installation of all Windows Updates
4: Installation of Free Comodo Internet Security
5: Double click on Comodo’s systemtray icon or execution of start menu entry
One or two sentences explaining what actually happened:
Scanner seems to work. Widget is visible. The main user interface of Comodo doesn’t show up.
One or two sentences explaining what you expected to happen:
I expect that is shows up but nothing happens.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
I’m not sure about the problem. Possibly, it’s caused by incompatiblity with graphics adapter.
Any software except CIS/OS involved? If so - name, & exact version:
Latest driver for graphics adapter, “Intel HD 4200”.
Any other information, eg your guess at the cause, how you tried to fix it etc:
I have Firefox browser installed with a theme/skin effect. But the skin isn’t visible (on all other computers this works fine with the same browser and the same skin).

Exact CIS version & configuration:
The latest version from date 09-13-2015.
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
AV, Sandbox, Firewall enabled (default configuration after fresh installation).
Have you made any other changes to the default config? (egs here.):
I changed nothing.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
It was a fresh installation on a fresh OS installation.
if so, have you tried a a a clean reinstall - if not please do?:
Clean reinstall after execution of GeekBuddie’s removal script resulted in the same behavior.
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
Config was untouched after fresh Comodo installation.
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 (64 bit), SP 1, latest Windows Updates installed, User account with privileged rights, real PC (no virtual machine)
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
No other security software ever installed (except Windows Defender which came with updates).

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
Always attach the diagnostics file (instructions on how to do this provided here) and the KillSwitch Process List (instructions on how to do that provided here) and put the resulting file in a zip file. Both should then be attached to your post.

All bug reports need to be formatted using the required format which can be found here:;msg743135#msg743135

Please feel free to reformat your report and we can continue to process it.


Thanks for your attention!

I have inserted your requested report. I don’t have a diagnostics file or the process list, sorry! Comodo isn’t installed any longer.

One of your GeekBuddys tried to help me detecting the problem’s source but he stopped investigation after a few minutes.

  1. What happens if you run ‘Virtual Desktop’ from widget?
  2. Is ‘cis.exe’ process running (in Task Manager) after you launched main interface?
  3. What happens when you click on “Secure” from widget?

Unfortunately, I cannot check your requested information because in the meanwhile I installed Intel Driver Update Utility. This Tool found a newer driver version for my graphics adapter. Since then, Comodo works fine and Firefox as well.

Indeed, it had something to do with graphics adapter driver. It’s absolutely inacceptable that Comodo’s antimalware solution can be interfered in such a primitive way! You need an additional simple variant of the main user interface in order to tackle such cases where graphics driver currently doesn’t accept a “fancy-schmancy” UI!

Glad that you were able to solve it.
In that case, I will move this one to “Resolved” section.

Thank you.

But are you going to fix this issue in any way? It would be embarrassing if malware interferes Comodo in such a way in future.

I’m just a volunteer. I cannot forward it since I would have to provide additional information and that’s not possible.
Regarding risk-- the malicious file would be sandboxed from your description. From your description, virtualization is not affected.

If you want then you could re-install the old driver (by comparing it with date that you’ve posted) and check again. Currently, there is insufficient information.

Hope it helps.

I see. I appreciate your support.

It sounds reasonable that the driver was possibly auto-sandboxed. If something like that happens again then this will be the first thing I’m going to check.

Currently, I’m not motivated to re-install the old driver and playing the game again. I’m glad that everything works fine, now.