USB network adapters can bypass the firewall

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, configuring web filter to block certain websites.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: I set filtroweb to block a term any * ad .
2:. Even after rebooting, and browse a page any sites with the term * ad
3: The problem occurs when using a USB network adapter
One or two sentences explaining what actually happened:
Filter Web not filter custom settings
NOTE: widget also does not display the inbound traffic and outbound firewall. It is possible to surf the internet even blocking all network traffic
One or two sentences explaining what you expected to happen:
The module should work on any independent setting of the device used to connect to internet
[B] If the software compatibility problem have you tried the advice to make programs work with
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
Apparently CIS is not capable of filtering all network traffic if you are using an external USB network device, for example. Even excluding all the default configuration of web filter, comodo internet security fails.

Exact CIS version & configuration:
Comodo Internet Security
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Antivirus active (statefull verification)
Active HIPS (secure)
Active firewall (secure)
active web filter (custom mode)
Active Sandbox (standard mode)
Have you made any other changes to the default config? (egs here.):
I changed only the web filter settings, excluding the predefined policies.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
It has been a clean installation
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
Yeah, so I tried to delete the web filter default settings
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 Technical Preview Build 10049 (32bit) , active UAC,admin, real machine
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=no b=no

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
It is not necessary.

[attachment deleted by admin]

  1. Can you go to Control Panel > Network and Sharing Center > In the left menu click “Change adapter settings” > Find the USB network adapter and right-click it and then click “Properties” > See if you can find “COMODO Internet Security Firewall Driver” in the list.

  2. If the Firewall Driver is present then can you please take a screenshot of the webfilter rules? I’m not sure I understand what you’ve entered to be blocked.

  3. Could you please mention maker and model of the external USB network adapter?

A fact that forgot to watch before sending the bug report.
Comes another question, if I can uninstall COMODO driver, I will get navigate quietly without being bothered, CIS does not issue any warning about uninstalling your driver (and should).
Both in their observation and my report, failures can be considered. After all, most users would feel safe, even if the firewall does not detect, alert or block an intrusion or leakage.
The default behavior should be install COMODO driver to each device, protect against desistalação and in the case of manual uninstall generate an alert.

[attachment deleted by admin]

[at]liosant, I think that running diagnostics should fix uninstalled drivers and related issues.

Hope it helps.

The “diagnostic” does not display error and leads the user to believe that he is safe.
The image is an onboard adapter and removed the comodo driver without any error message.

[attachment deleted by admin]

Hi liosant,

It is not clear whether “COMODO Internet Security Firewall Driver” is present on the USB adapter.
If it’s not present then what happens if you manually install the driver? Anything interesting?


With the newly released version of Windows 10, on July 29, the problem was solved

Thanks for letting us know this is fixed with the latest release. I will now move this to resolved.