USB Disk Security as Trusted App ignored by Proactive Defense[RESOLVED]

Hi, I have just installed COMODO Firewall, and I must say, it IS better than Windows XP SP2 Firewall.

I do have 1 concern though.

In today’s world of USB Flashdrives, one must have specialized protection against USB Flashdrive threats. I opted for USB Disk Security by (I only have the shareware version).

Too bad for zbshareware, they didn’t digitally sign the darn thing. So Proactive Defense keeps on blocking USB Disk Security’s “access memory” attempts (target: cmdagent.exe).

I try to put it in “My Own Safe Files” list, only for Defense+ to tell me that, “USBGuard.exe is already a safe file.”

So I try doing something about it under Defense+ → Advance → Computer Security Policy. I set the USBGUard.exe process as “Trusted Application”. But Proactive Defense still blocks its “access memory” attempts.

In fact, the only way I could stop the Proactive Defense list of blocked suspicious attempts from getting longer is if I set the Defense+ Settings to “Disabled”.

What can I do about this? I am at a loss. COMODO people, please help me.


I had similar problem and after combining several settings, maybe this could help you (see screenshots).

[attachment deleted by admin]

Unfortunately, no…it doesn’t help at all.

It makes no sense why it doesn’t.

Still need help here… The list is 521 and counting.

It is really strange. This helped me. Maybe someone will come with another idea…

Did you restart or anything like that?

Screenshot below add your application in the top last screen this will allow access to CIS memory.
Please click apply to all screen that are open.

[attachment deleted by admin]

Dennis2, it still won’t work.

The Defense+ has blocked 721 suspicious attempt(s)…

…the list is still getting longer.

Have you checked back to make sure it is in the list?

Yes. It is.

Do I add all the Windows System Applications as well, or just USBGuard.exe?

As Dennis has done it in pictures lets try it in steps.Remember we need to “Add” the USBGuard.exe and any others associated with the application to the “Interprocess memory access”/Exclusion list for Comodo Internet Security.

1.Defence+/Advanced/Computer Security Policy

2.In the list locate the entry “Comodo Internet Security” and double click it

3.Click on “Protection Settings”

4.Click on “Modify” next to “Interprocess Memory Access”(a window will appear called exceptions)

5.Click on “Add” then Running Processes then double click USBGuard.exe(and any other associated)–>You should now see it appear in the exceptions list at the bottom.

6.APPLY to close all windows

7.Repeat the above to the point where you get to the exceptions window to make sure it is there

Let us know


Praise the Lord for you guys.

Thank you all, Daniel Jackson, Dennis2, and Matt.

I can now sleep…3:41am here…

Thank you again.

List has stopped at 1023 blocked suspicious attempts…

Nice 1 VGI and by the way welcome to the forums,

I`ll mark this thread as resolved if you should need it reopening pm an online mod