Upgrade CIS 8.4 to 10 - GUI problems on Win 7 Pro

My OS is Windows 7 Pro and was instaled CIS 8.4 - work good. After upgrade CIS 8.4 to 10 - I receive problems with Win 7 Pro GUI interface

see attached screenshot: comodo err01.jpg

after I change Theme from one to other in CIS apllication then restart this soft and make Start Menu → Log off - then all look good

see attached screenshot: comodo err02.jpg

But after next restart of PC - this problem repeat

I’ve had similar problem.

After updating to CIS 10, Aero theme gone, unable to select any Aero theme (greyed out in desktop customization window), Windows own troubleshooter saying desktop window theme manager not running and unavailable (though Task Manager showed both service and exe running/enabled).

Additional problems - takes ages starting up if logging on promptly, but stuck at ‘Welcome’ timer with no desktop ever appearing if leaving logon screen for a couple of minutes before logging on. Plus browser (firefox) locking up for minutes with repeated ‘plugin busy’ messages before finally loading any page requiring Flash or Silverlight.

Made some progress - at least the desktop theme/GUI and initial startup time problem. It’s the VIRUSCOPE. Disabling viruscope, startup is back to normal and GUI with Aero theme back to normal. (Hasn;t helped with the massive delays of any page using Flash or Silverlight loading, though).

No idea how to get Viruscope working, but at least disabling it has let me use the computer again as a workaround.

I used to be very tech minded, beta tester of several software products, adept at figuring out tests to narrow down problem sources, nailing down bugs and making detailed reports. Then I became disabled. permanent pain, typing ramps it up quickly. Permanent prescription pain killers fog my head, can’t focus, can;t concentrate, cn’t think clearly. Can’t use computer for long. Can’t do all this diagnoatic stuff, downloading this and tht to create comprehensive reports taking hours. Need software that works, can cope few minor bugs, nto big stuff. If this isn’t easy to sort out withoutmajor diagnostics, testing and postingk, will have to dump CIS, find some other security software that just works easy.

Oh - I should have said disable Viruscope and then Restart the computer.

I think this is not Veriscope problem. I disable it but problem repeat

I don’t think it’s caused by CIS. Is the issue gone if CIS is uninstalled?

yes, when CIS 10 uninstalled - all work good

  1. Please attach a diagnostics report.
  2. Try killing all processes that correspond to CIS & re-launch CIS. Does the issue appear?
  1. CIS diagnostic not found problems

  2. kill & close all cis process - when do Start Menu → Log off - all OK, but if do Start Menu → Restart - again problem

That info isn’t really useful. My (initial) assumption is that a service is crashing and I’m trying to pinpoint when/why.

As I have exactly the same symptoms as the OP - after a start/re-start my GUI comes up in a basic, not the usual Aero theme; it also has the same padlock icon in the notification area as in the OP’s ‘comodo err01.jpg’, though in my case without the text message balloon and it disappears if I click on it; and the desktop Personalizatin tool has all the Aero themes greyed out and unselectable - I can’t help but think our problems are connected even if my ‘fix’ doesn’t work for him/her. Perhaps my having Viruscope on or off is affecting the speed of Comodo initializing and whether that interferes with the desktop theme management or not, whereas with the OP, different settings and machine specs cause the interference whether Viruscope is on or not?

I have located a HIPS/sandbox element to this too, though in trying to fix the problem after start rather than during start. Whether it might be impacting during the start/restart to initiate the problem I’m not sure and can’t think how to test it.

As I say, if I start/restart with viruscope disabled in CIS 10, the computer runs as normal, Aero theme as normal, Desktop Personalization offering all themes, including Aero themes as normal. With no other change than enabling viruscope, then after start/restart the computer launches with basic, non-Aero theme, that padlock icon in the notification area (but no text and disappearing if I click on it), and Desktop Personalization having all the Aero themes greyed out and unselectable. The really puzzling things are that (a) the Viruscope event log is completely blank; and (b) the Viruscope settings - unchanged by me other than enable/disable - have Monitor Sandboxed Applications Only ticked, so unless during startup CIS 10 is opening the entire main desktop in the sandbox (which it shoudn’t be and doesn’t appear to be) Viruscope shouldn’t be affecting anything anyway.

(By the way, in the Viruscope settings the ‘Manage the status of the recognizers …’ box is completely empty - is that correct, or should it have downloaded some recognizers from somewhere and have them listed, whatever they are?)

Now, this is where the HIPS and sandbox come in …

Having started/restarted with viruscope enabled so, like the OP, I have a basic. non-Aero theme, and the Desktop Personalization window has all the Aero themes greyed out and unselectabe, if I then run the Aero theme troubleshooter, I get a HIPS alert about the running of a ThemeTool.exe, and from the HIPS and Sandbox event logs, it appears that this ThemeTool.exe is sandboxed before i can OK it. The Aero theme troubleshooter then finishes with error messages saying that it can’t change the theme because the theme controller is inaccessible. And re-running the aero troubleshooter doesn’t help because although I OKed ThemeTool.exe the previous time, it is a different ThemeTool.exe each time.

Some internet searching tells me that ThemeTool.exe is created as a temporary file by the Aero theme troubleshooter whenever it needs it for one time use, when the troubleshooter needs to change the theme - it’s function, if used from the command line is to either return the current theme or trigger a change of theme to one supplied as a parameter to the command - so the Aero theme troubleshooter tries to change the theme to an Aero one by temporarily creating and using an instance of ThemeTool.exe, but fails because CIS HIPS is causing the ThemeTool.exe to be sandboxed each time.

When the temporary ThemeTool.exe is created, it’s as C:\Windows\Temp\SDIAG_XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX\ThemeTool.exe where all the Xs are hexadecimal digits, different on each occasion. So simply allowing it (too late as it’s already sandboxed) doesn’t help for a further attempted use as for the next one all the Xs are different so the specific alowance rule for the last instance doesn’t work.

Where and how does one OK any instance of ThemeTool.exe which will work despite the different SDIAG_XXXetc each time? For one thing, I’m wondering if a temporary ThemeTool.exe is created and used to change from default to user used theme during startup, and it’s being clobbered by the sandbox while both CIS and the desktop are initializing?


I’ve discovered more … and that while what I wrote above is true, it’s misleading.

With settings Antivirus: Stateful, Auto-Sandbox: Enabled, HIPS: Safe Mode, Viruscope: Enabled and Firewall: Safe Mode, on start/re-start the desktop comes up in a basic non-Aero theme. The Personalization window has all the Aero themes greyed out and unselectable, and the Aero troubleshooter says that Aero themes can’t be selected because the Desktop Window Manager Session Manager is unavailable despite the Task Manager showing the service as running.

As described in my previous posts, with all those CIS components set the same except for disabling Viuscope, starting-re-starting the problem disappears, the desktop comes up with my usual Aero desktop them, and all options including the Aero ones are selectable in the Desktop Personalization window.


On further testing, with all those CIS components active as above including Viruscope, but disabling Antivirus instead, again on start/re-start the problem is also gone, the Aero themes back again.

And with all components active except for HIPS disabled, again there is no desktop theme Aero problem.

And with al components active except for the Firewall disabled, again there is no desktop theme Aero problem.

In fact, disabling ANY one of the CIS elements causes the problem to go away apart from Auto-Sandbox - all others active apart from Auto-Sandbox disabled there’s no Aero themes again.

So, the problem isn’t specifically with Viruscope as I previously thought. But it IS something about CIS 10 (had no such problem ever with CIS 8). With Antivirus AND HIPS AND Viruscope AND Firewall ALL enabled, no Aero themes available and the Desktop Window Manager Session manager unavailable despite being reported as running. Disabling any one of those four CIS 10 components the problem disappears.

As I said, weird. Suggested fixes welcome.

Hi David,

I’ve followed your posts but there’s no issue on my system.

By the way, are you using SP1? Some users reported incompatibilities with older versions (for example, some CPU features might not be supported by Windows and updating could solve such issues).

Could you kindly attach a diagnostics report?

I have the same problem as these other people. Also using Windows 7, and the problems started when I restarted my laptop to upgrade to CIS 10. Please look into this!

developers will do something to solve this problem ?

or move post to other place mean that they not see problem?

I’ve found a fix for this problem, which has also fixed another longstanding problem I had all the way through CIS 8 that persisted with CIS 10.

To recap the problems:

  1. With CIS 10 installed and most/all modules active, my computer started/re-started with only a basic desktop theme, all Aero themes unavailable.

  2. With all CIS 8 versions as well as CIS 10, if I logged in promptly on start/re-start, at the end of logging in and everything finished starting I would get a message that Comodo had failed to start, would I like to run the Comodo diagnostic tool?. The diagnostic would report no problems and I’d then have to start Comodo manually. However, If after reaching the logon screen I left it for 3 minutes before logging on, Comodo would have started properly after the logon.

Problem 2 I’ve been living with since starting using CIS 8. But problem 1 was so bad I gave up, uninstalled Comodo, looked through other AV products and installed one.

However, I wasn’t really happy with my replacement and found myself thinking about the Comodo problem some more. Problem 2 seemed to indicate that at the point that Comodo was starting, either something else starting at the same time was interfering with the Comodo start, or something else hadn’t started yet that Comodo needed to have started first. And following that thought, it seemed to me that problem 1 might be that Comodo starting when it did was interfering with the startup of the desktop theme manager.

If that was the case - and I remembered that some of the other Firewall and AV programs I’ve used before had configuration options to delay startup at logon to resolve conflicts, although I’d never needed to use those options with them, but clearly this meant this was a possible problem with this kind of software - then it occurred to me that if I could somehow take control of the order of programs starting at logon and delay Comodo’s start it might resolve the problems. Couldn’t find a way to control the startup order within Windows 7, so thought that somebody would have written a utility to do it, Googled and found the program Startup Delayer by r2 Studios - which has a free version, or one can pay to activate a few extra facilities. Free version is fine for this CIS situation.

So I read the documentation, uninstalled my new AV program, reinstalled CIS 10. Problems 1 and 2 still there with CIS 10 as expected. Installed Startup Delayer, opened up its configuration. In the list of startup applications, dragged CIS 10 up to the list (otherwise empty) of programs to have their startup delayed by Startup Delayer. Then opened the Options, Launch Process pane, ticked the option ‘Ensure these processes have completely loaded before continuing’ and added dwm.exe as the only entry in that list.

Done, restarted computer and CIS 10 now fine after start/re-start - desktop normal, Aero theme as normal, and CIS 10 also starts properly even after I logon as soon as the logon screen appears which it never has since I started using CIS 8 a couple of year ago.

To recap problems AND solution:

Left to itself, there was a problem of CIS 10 startup interfering with the desktop window manager startup, causing the computer to start with a basic, non-Aero theme and with the theme manager unavailable. Further conflict at startup prevented CIS itself starting properly requiring manual start of CIS at the end of the startup leaving myself connected to the internet for a little bit of time before CIS had fully started.

Using r2 Studios free Startup Delayer (or probably other utilities - that’s just the first likely looking one I found googling) to take control of CIS 10 startup and have the CIS startup wait until after the dwm.exe had finished loading solved both problems. Desktop themes back to normal, and CIS successfully loading and running fully well before internet connection made.

Problem solved, so I can now carry on using CIS 10 (although i have one remaining problem over the effect CIS 10 has on browsing pages with Flash or Silverlight content).

I am, however, not feeling well-disposed towards the people who create CIS10 over this. I had to diagnose this myself, hypothesise the cause of the problem myself, figure a possible solution in term of needing additional 3rd party software of a kind I’d never seen before (not having had reason before to need it) myself, google and find the needed software myself and check its probity, install and then figure out how to configure it myself. If CIS 10 was professional software of the robustness to be expected of professional software, it should itself contain measures to avoid startup timing conflicts. Or, at the very least, contain a configuration option to delay its startup a little, as certain other firewall and AV products I’ve used had, specifically to overcome problems over startup order clashes like this, with appropriate documentation so a user with problems like this will find the cause and action to take (select the option to delay startup) within the product’s documentation. Here, with CIS, there’s no option to deal with the problem within the program, no help in the documentation, and no help here in these support forums either that I could find through search, or offered in response to my posts. Very poor show.