Updating from 2674 to 2708 removes items from config [M240]1[v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: most likely
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:

I use config derived from “Proactive Security” config also I have removed default configs leaving only mine with custom name. There are certain differences between configs which I always compare with use of WinMerge. Today I’ve updated to 2708 revision and I have done a comparision of what CIS messed in my config (it loves to change things). I’ve noticed it removed:

  • from “Pseudo COM Interfaces - Privileges”
  • from “Pseudo COM Interfaces - Important Ports”
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:

As you can see those rules are not present in “Internet Security” config, so CIS upgrade degraded my security (“Proactive” have them).
Also note that I’ve removed default configs (maybe this was a mistake) and now on the first place is mine (as I remember the list was “Internet”, “Firewall”, “Proactive”, so my config is now at “Internet” place - this is why it ate entries?).
This also happened in some 5.x version.

  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- CIS version & configuration: 6.0.264710.2708, own

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: FW
  • Have U made any other changes to the default config? (egs here.): yes
  • Have U updated (without uninstall) from a previous version of CIS: yes
    [li]if so, have U tried a a clean reinstall - if not please do?: no
    [/li]- Have U imported a config from a previous version of CIS: yes
    [li]if so, have U tried a standard config - if not please do: no
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: X Pro, SP3, 32b, admin
  • Other security/sandbox software a) currently installed b) installed since OS: no

PM me for pwd.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


2801 - unfortunately I’m unable to confirm existence of this issue because before the update I’ve left three original configs as the first ones and my config was on the fourth slot, however after exporting my config after update to 2801 it matched to the changes done to proactive config from 2708 to 2801 version, so it was treated as proactive now

So that’s a probable fix if I understand correctly?

Keeping original three configs and our private as a 4+ config? Well, I’d rather call it a workaround.
Or if you ask if 2801 fixed this - I don’t know I just forgot to test it before updating and now it’s too late…

That is what I am asking. :slight_smile:

OK, will leave as last observed in 2708, and no fix for the moment

Thanks for feedback

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Could you provide me a link to previous version installer (6.1.276867.2813) so I could reinstall it as I’ve upgraded without minding to test it, again.

and if you need older versions just click on the sections for older versions. Let me know if you have any other questions.

Umm, aren’t there official Comodo repositories somewhere available? I never download software from 3-party sites especially when I can’t verify a hash at least.

Unfortunately not sorry.
I agree there should be.
[Wish] Archive of previous versions available for download direct from Comodo.

The site is safe. I have used it multiple times. However, once it’s finished downloading you can check the digital signature and ensure that it is still valid. If it is then there is nothing to worry about.

Actually, QA has flagged this as fixed. Thus, I will move this to Resolved.

Please let me know if it is not fixed for you.

2860 - unfortunately the only change between 2847 and 2860 is “ProductVersion”, however I haven’t found any unexpected changes (I’ve imported 4 copies of current config into first slots before the update process, so the first three overlaped with the default configs, then compared before&after).

I assume this is indeed fixed until future encounter, if any.

Thanks for checking. Please do let me know if you find that items were removed.