Can anyone tell me why i might be unable to update my anti virus signatures, when i click on ‘update now’ it just pops up ‘failed’ and tells me to check my internet connection. But my internet is working fine, what could be wrong? g

With me it was auto updating at the time.
Current VDB version: 983

I get exactly the same error message for antivirus updates. The CIS update works fine.
I am behind a proxy server at work.

Mine says application is not running but as I have only had this for a month, I don’t know how to fix it. Help. Should we reinstall?

:o I am that no one has answered these questions and unfortunately I started having the same problem yesterday with the auto updater getting about to 9% and saying that it has an error. It explains to me that the internet connection was interrupted but I have cut off netwaiting and my email program. So what is up folks? anyone with any ideas?

By any chance have you blocked ‘cmdagent.exe’ from connecting to the internet?

I was testing what I could and could not block only earlier today and found that if I blocked this exe that the AV portion of CIS would not update.

The program updates are downloaded using the ‘cfpupdat.exe’, so you need to ensure that both of these have outbound connections enabled.

I have 'cfp.exe. blocked and have not noticed any ills thus far.

Hi all,

I’m not new to Comodo, but just created a new account…

Product Version: 3.8.65951.477
Virus Signature Database: 1017

Error message: “Update failed. Please check your internet connection”

Still the same error messages occur with 1. Firewall off 2. setting a proxy for connection. Any idea what’s wrong?

i’m another user that can’t get update too

Hi Everyone,
We have checked our download servers and they seem to be working fine.
Going forward to resolve error, we would need following details:

  1. Product Version as present in About dialog
  2. Virus Signature Database Version as present in About dialog
  3. Snapshot of error as you get while updating “Antivirus–>Update Virus Database” section
  4. What happens when you check program updates using “Miscellaneous–>Check for Updates”. Does this also error out?
  5. Are you behind proxy?


Does anything on this thread help?

I’m a complete idiot.

I didn’t check Comodo’s proxy settings, and that’s what’s causing the problem. Its using an old proxy that I no longer used.

CAV was using IE’s old proxy settings, which I didn’t change after my reformat, and CAV was the first thing I installed. I changed the proxy at a later date, but CAV did not refresh its settings i.e it didn’t get updated proxy settings from IE. Perhaps this can be rectified so that CAV will refresh its proxy settings to prevent such further incidents? I understand that there’s a “update from IE” button, but I really didn’t notice the proxy section of the settings.

In any case, my sincere apologies for not doing a detailed analysis before posting and for wasting everyone’s time, and for anyone else who’s still having problems, I recommend that you check Miscellaneous–> Settings → Proxy.

Not a waste of time, skyfire101. We all learned something from this :slight_smile:

I’m also having the same problem, is there another way I can get the updates? No! I’m not behind a proxy.
(I’m running WinXP-64bit) It was working fine up to a few days ago, when I lost the TCP/IP stack and had to rebuild it. Now my internet seems to be working fine even IE7-64bit, except getting virus updates from Comodo. Thanks for your help.

see attachments.

[attachment deleted by admin]

You may not be behind a proxy (neither was skyfire101). But have you checked your settings?

Yes, I did, nothing is checked or filled in as far as the proxy settings. I just used Comodo registry clean and did the registry fix that was recommended at https://forums.comodo.com/anti_virus_bugs/cant_update_virus_database_cis_3571735439_merged_threads_resolved-t29013.0.html;msg226178#msg226178

Now when I reboot I get a blue screen at startup and goes into a reboot again. Even safe mode will not work. I’m in the process of doing a complete partition restore.

These are the settings:
[HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\0\AV\Settings]

[HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\1\AV\Settings]

[HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\2\AV\Settings]

[HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\3\AV\Settings]

After changing this , reboot , and it works.

  1. Ver. 3.8.65951.477
  2. DB ver. 973
  3. “failed to update the virus signature database. Please check you internet …”
  4. No error. “There are no updates aviable”
  5. proxy do not use

My reg. already contained all line “UpdateURL”=“http://download.comodo.com/”.
The Problem remained.

Hi siao,
Can you please tell us value of “UpdatePath” from following registry entry:
HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations\0\AV\Settings


Please make sure you also check the Configurations[b]x[/b]\AV\Settings where x would be a number from 0 to at least 3, and 4 if you have used “Import As” to import your previous configuration.

Hi umesh!
Ver. 3.8.65951.477 - my first deskside

  • siao

[attachment deleted by admin]

Mine is close, when i click on ‘update now’ it just pops up ‘antivirus engine not initialized’. I don’t remember a prompt to do it, the version is 3.8.6591.477 - any ideas??? ???