Updates stuck at 30%; Unable to Scan

Okay, I just installed Comodo Antivirus last night, and it started to update right afterwards. I checked on the update about ten, maybe fifteen minutes later, and it was at 30%. I check about ten more minutes later and it is still stuck at 30%. This morning, I’m trying to update it and guess what? It’s been stuck at 30% for the past 5-10 minutes.

Normally, I’d attribute update slowness to my internet connection (768 Kb/s DSL - used to have twice that) but this is bloody ridiculous.

Exactly what is going on with this program that’s not only causing it to not update, but to not start any of the scans I ask it to start? Chances are I probably do have a virus already, but the thing is, if I have to reinstall Windows, I won’t be able to - I bought this computer from a friend for cheap and it didn’t include a Windows XP disk. And quite unfortunately, I don’t have the money to get a new install disc nor the money and hardware to even get or be able to use Vista.

So basically, what is wrong with my Antivirus? If you must know my computer has the following…

  • Pentium 4 1.5 GHZ
  • 768 MB RAM
  • 40 GB HD

I suppose what kind of video or sound card doesn’t matter. But still, I hope you will be able to help me.

-edit- forgot some stuff - I’m using the free version of Comodo Internet Security with both Antivirus and Firewall, and I’m not doing anything else while trying to update.

The initial update of the AV database is fairly large, approx 45 MB and it happens with several steps.

During this process the progress indicator will stay at 30% for quite a while. My advice is to give it its time. The process is quite memory consuming as well; so people with 512 MB or less will have quite some paging, read hard disk, activity going on as well slowing things down.

Try giving it a couple of hours for now and when time is not on our sides please report back.

My first signature file was 100MB+ ! :o

The best way to get insight into the process of signature update:

  • initiate the update as always
  • in the main CIS window (Summary tab) click on the blue underlined number next to the inbound/outbound connection(s) sign
  • observe Bytes In column for cmdagent.exe process.

It’s all you need. You can even estimate the download rate by watching what amount of data has been downloaded in the last 10 seconds for example.

Alright cool. Thanks, that actually is how it worked last time. However, I’m having to redownload the signatures today because my antivirus somehow got uninstalled last night and I lost all of the files in My Documents thanks to a really nasty problem with GameGuard (■■■■ rootkit).

Eh, time will hopefully be on my side once again, and the problems will be solved in the next couple of hours. Takes me about less than thirty minutes approximately to download 100 MB, and even less if the signatures are 45 MB.

I guess this will give time to have a decent breakfast and take a nap before I scan.

To All,

There is also an FAQ answer for this question:

Hello everyone, I’m new here.

I have been using COMODO for about one year now, but lately I had to format my PC and consequently needed to reinstall COMODO too. So I downloaded the latest version 3.10.102363.531, installed it, and the 30% problem showed up.

Googled the issue, found this topic. So I let the updater try and try, and monitored the download via the Active Connections window, where it read that over 100 MBs were being downloaded, but when it finished downloading it said absolutely nothing and on the Virus Defense part of the summary it read that the signature had never been updated. So I tried to update again, and I got a message asking to reboot for the changes to signature to take place. Fine, I rebooted my system and went to check whether or not the signature was finally updated. Nope.
I repeated the process a couple of times, until I got tired and removed COMODO completely. I decided to install a previous version, 3.5.54375.427, and see whether it works.

Well, when I tried to update the signature, the process started like usual and got stuck at 30% for less time, but it eventually got to 100% and said the signature has been updated (I checked how many MBs were downloaded, I can’t remember the exact amount but far less than 100 this time, maybe little over 40). Quite strange, I think (actually I suspect the updater isn’t working anyway, despite what it says). Furthermore, if I try to update via the Check for updates option in Miscellaneous screen, I get the following error:

Error 108: Update could not be completed. Please check your Internet connection settings.

No need to say, there’s nothing wrong with my connection, because:

A) This issue is happening and this message is being sended from the same PC
B) When trying updating via “Check for updates” option with the newer version of COMODO I get no error, but a message saying that no updates are available.

On a side note, I remember I had been experiencing this same Error 108 issue before formating, but I hadn’t time to pay attention to it back then.

How to get any of these two versions working correctly? Thanks!

Hello Darkzero,

Welcome to the forums, sorry to hear that your running in to trouble.
First all AV database versions previous to 3.10.x.531 are no longer updated, so if you install an old version you will get stuck on an old AV database, so that’s useless if you run the AV.

The 3.5.x version cannot be automatically upgraded to 3.10.x so it needs a clean install, it would have been better though that there was a clear “Error” telling you that an upgrade was not possible and that a uninstall/install was needed…

For the 30% issue, can uninstall 3.5 and reinstall 3.10.x again, after the first download and reboot the GUI will still tell you “Never updated” that’s a bug, but after the first run can you please check the Filesize of the following file c:\program files\comodo\comodo internet security\repair\bases.cav if I’m correct it should be around 103MB of size. And also check the GUI, MISC, About box to see what version of the AV Database is loaded ?

Hi Ronny,

thanks for replying. I just removed 3.5 and reinstalled 3.10. It downloaded the database during setup, but after rebooting it still said that it has never been updated. I re-ran the updater (which is still going right now) and then saw your message.
The bases.cav is 51,3 MB, not 103 MB. The Signature database version is 1157 according to the About Box.
The updater has downloaded about 44 MBs now, I’ll see what the bases.cav’s size is after it has finished and if the version number has changed, and I’ll let you know.

Thanks again!

Ok, update completed. About 106.6 MB were downloaded, but the bases.cav file is still 51.5 MB.The whole repair folder’s content is around 60 MB. The database version, though, is now 1844.
What do you say?

Did you reboot in between ? because you still need an other run of updates after 1844 it needs to boot.
I’m at 1946 at the moment…

Yes I did reboot. I’m going to sleep now, I’ll try to run updater & reboot again tomorrow and see if I can get 1946… I’ll let you know. I just hope this is going to be fixed soon…

Don’t ask how. I don’t know. I did nothing. I just re-opened comodo GUI. The “never updated” message disappeared, it says that it has been updated, and version is 1946. The file you mentioned is still 51 MB… Maybe tomorrow is going to be bigger?! ???

I’ll keep you up-to-date…

The file copy won’t take place if you don’t reboot, so it will depend on a reboot.
Do you have time to reboot ? I’m very curious if the file is larger then…

Rebooted. Again, the whole repair folder is around 67 MB.

I Darkzero,

I have checked it out on a clean install and this behavior is not present so it should be good now.
I have seen this on an “upgraded” CIS version that’s why i asked.

I’m on DB 1951 at the moment, so if yours is also then the problem is solved ?

My version is also 1951, bases.cav always 51,7 (or so). Is that ok?

In repair is ok, in \scanners it should be around 107MB large.

In scanners is 105 MB. I’d say it is at least satisfying… ;D

Okay just to make sure, we can check the SHA1 hash of the file:

DB 1952 - SHA1 = F9A895B8BD5C8160CB122E739510E3D2620ECC81

If you need a hash tool you can find one here:

You can start the program and open de bases.cav it will calculate the Hash en right clicking in it will allow you to copy the SHA1 hash.

Too late - my DB is now 1953 and SHA1 is