Update View Logs not working

V12.2.2.7036 (Firewall only) Windows 7 Ultimate 64-bit

Exactly two weeks ago I performed Update from the CIS General Tasks window, all went well then with no errors, see attached image UpdateCompleted.jpg.

Today I did exactly the same thing but this time I got an Error on “Download websites database”. In an attempt to check what went wrong I clicked on View Logs in the bottom right corner however, nothing happened no log showed up. View Logs seems to be disabled or not working as it should. See the attached image UpdateErrorAndNoViewLogs.jpg.

Rebooting PC and performing Update again seemed to solve the “Download websites database” update issue, no error on that item this time.
Surprisingly is that after performing another Update the “Download websites database” item was not listed in the update window anymore and the update window showed the same result as two weeks ago as shown in image UpdateCompleted.jpg.

After another reboot some hours later I performed Update again. It completed with no errors but the “Download websites database” was again listed in the update window. Right after the update I did another update that also competed without any errors but this time “Download websites database” was not listed in the update window anymore as shown in image UpdateCompleted.jpg.

Any pointers as to why the “Download websites database” item appears and disappears in the update window list?
Also is there any reason why View Logs isn’t enabled or working to check what went wrong in case of an Error (note: it even doesn’t work when update finished without errors to check what was updated or downloaded)?

Addition to first post.

I managed, after another reboot, to take a new screenshot of the update window which is now showing all items including the appearing/disappearing “Download websites database” item.

Presumably if the Website Database Check shows there is no update needed, then there isn’t any point in showing a Website Database Download

If the check shows a Download is necessary, then the Database Download would show

As for the logs, I can only guess that if it shows a download, you can check on the about GUI to see the Database number. The error (which is a common and intermittent problem) would show in the GUI that the Database version hadn’t changed. Any logs wouldn’t give anything other than success or fail, which you can already see

I just rebooted (I mean cold booted actually) my PC and performed update again.
The “Download websites database” item is listed in the update window again but it throws an error this time. Presumably, like you say, because of no Database version change and the known common and intermittent problem.
The “Download websites database” item now stays in error state even after many Update attempts (I guess a cold boot would solve it again as it did before in my first post).

Up to now is seems to me that the “Download websites database” item is always listed after each cold boot (with or without error) and that it disappears from the list when database download was successful or maybe just “Up to date”.

If the websites database version hadn’t changed why not listing it as “Up to date” like the other items in the update list? Showing an error instead is confusing.

As for the logs, so they do not provide any detailed or additional information about update errors which could be used in error reporting for solving update errors?

I decided to install CIS on wife’s laptop recently. I got the same website database error yesterday on her PC. Just prior to writing this, I got the same error on my PC, and yes view logs is greyed out.

The ‘Error’ is a common and often reported issue, that is a Comodo server problem and usually Geographically dependent. There are numerous reports on it going back years. It’s showing that in the UK & obviously in other areas. The Database is checked and if a download is necessary, that will be attempted . . . usually being successful and sometimes not; as now

If the download isn’t necessary, then obviously a download won’t be attempted or shown as the Database is up to date

It’s a server connection issue, not a CIS or FW issue. There are no logs to see

Thank you for clearing this error up.

Just now after a new cold boot “Download websites database” is still in error state, obviously a reboot doesn’t seem to resolve the error, it’s a server connection issue.

It would be nice and handy though if CIS would report detailed error logs about the update process in general which could help track down update issues.

Would like to add the observation I just made right after my previous post…

I did not reboot or restart PC, kept on trying updating but “Download websites database” was still in error state. All of a sudden after another update attempt the error was gone and it said “Download websites database” Completed. Then I did another update and the “Download websites database” item was removed from the list. The “Websites Database” version in the About dialog was updated to a newer version.

Now with the above observation, the “Download websites database” error is either a server connection issue OR it is just trying to tell to the user that the websites database is “Up to date” as I presumed earlier. To my believe it is the latter interpretation.


Did another update just a minute later and “Download websites database” is yet again in error state.
This enforces my strong believe in the error being a “Up to date” message to the user…

I’m afraid not. It’s a server connection / download Error as it shows . . . ongoing and well documented issue.

Was my post EDIT included in your answer too?

I have captured three video frame images of the update window during the “Download websites database” update process . . .

The three video frame images reveal in the green status bar that there IS a connection with the server and that a zip file IS being downloaded from the server and yet “Download websites database” is in error state . . .

That is the stage of downloading which eventually fails . . prior to the error . . . server / connection. Your Database number hasn’t changed and won’t until the server connection is fixed

Could be, but in the green status bar it says “3.00MB/3.00Mb” which means to me “Server has downloaded 3.00MB of a total file size of 3.00MB”, not?

It also says 25% in the green bar. Check your Database version . . has it changed from the start of this or not?

As for the 25%, I re-checked the captured video from start to end, the update process stops after 76% and then throws the error in the update window. You are right 25% is missing to reach 100% in this update. The missing 25% had to be downloaded from the server during the “Download websites database” update process.
I thought it only needed to download 3.00Mb but that was only one small chunk of a larger zip file it seems.

The Database version number only changed in post #7, not afterwards anymore.

I rest my case, the error is a server connection issue.
Hope they will fix it one day.

We all do . . but it’s come and gone for years now. Usually the Europe / UK side is ok and it hits the US more, but it varies

New information…

When “Download websites database” is in error state the update process seems to download the “ctrl-06-22-url.db.zip” file from here:


which was being redirected (in my test case) to here:


The “ctrl-06-22-url.db.zip” file can be downloaded using a normal browser from both above mentioned locations and is only 3MB in size.
The file can be unzipped/unpacked without errors. So the correct file is on the server and very small in size.

Seemingly CIS fails to access the zip file on the server for some reason or fails to process or handle the correctly downloaded zip file in a correct way resulting in the “Download websites database” error.

When a new database version is available CIS manages to download and process the new zip file correctly.

The view logs on error will only work when there is an actual error code, in this case the unspecified error has no error code so view logs wont work. As mentioned before, CIS sometimes has issues with downloading/installing website db updates, even if you can access the file through a web browser, CIS will still fail to properly update the websites db occasionally.

Thanks a lot for your feedback, also many thanks to Ploget.

I fully understand the situation around this issue and also that they are working on it for a long time to fix it.

In my previous post I only wanted to point out that, at least on my system, CIS managed to download the database (the zip file) correctly but that the installation of it failed for some reason which I suspect to be the database’ same version number (database in “Up to date” state) causing the shown update error.
It just might be not a real error but just a “Up to date” state situation instead. But I could be wrong in my assumption.

This is due to the small glitch during websites database update, just a restart can solve it. We have encountered this issue a while ago but not in the recent days. As you mentioned, again now we have noticed issues with website db updates.

Thank you for reporting. We are looking into it.