Update trouble


I´m trying to update my Comodo firewall to the latest version
When i run the update tool it says it’s has updates available and i download them and install them but the version number doesn’t change. I have even tried to uninstall the firewall and download the most recent setup, but it doesn’t update then either. Am i doing something wrong or is it just not able to update your firewall. I currently have version installed. Please, help me anyone because this is driving med nuts… (:AGY)

Hi Marcus981

You will probably have to run the uninstall from here and reinstall the fresh download of


Thanks, will try that too. Hope it works! :SMLR

you are not the only one with this problem.


I have now tried to uninstall the firewall and run the CFP3 file and registry tool and when i try to install the new x32 setup that i have goten from the comodo page the scanner works and scans my cpu but the product version number still is I have read most of the other treads on this forum and they all seem to have gotten the firewall to update to, but i can´t get it to do that…It´s very odd startong to think that the setup that i get from the comodo page isn´t contaning the version. Please help me anyone!

There seems to be a bug in the “about” window in the firewall. I scanned through the bug section and encountered someone with the same problem as t have described above and someone told this person to check his file properties of CFP.exe and when i does that it says that i have the latest version I have just looked in the about window and it made me confused as to which version i had installed now it seems as i have been updated the whole time. If Comodo now just found out a way to update the about window then everything would be perfect.

I have a similar problem.

I updated manually to (from Everything seemed to work fine. But now the about window still shows version while cfpver.dat tells me that I have

When I try to do again a manual update, it tells me that updates are available. When I agree to download them, it tells me right away that they are installed (which is probably true…), but the about information still doesn’t change.

Some information on my configuration:
I am running Vista Ultimate and I started from version (which is the entry under “Product Version” in the registry).

How can I be sure which version I have installed? I’m quite confident that it is the newest version since I was asked if I want to switch to the new configuration file type…

Its always better to do a complete uninstall of any product when there is an update. NOD32 just updated but instead of doing an over the top install I uninstalled the older version and installed the new ones. That way also you start off with a clean slate.