update to Free Firewall hosed my OS

Version 5.1.256249.2599 Comodo Free Firewall offered me a program update (which it hadn’t done in YEARS) this morning; installing it (to ver.7-something) hosed my (WinXP Pro sp3) OS.

Was the update incompatible with WinXP? Considering that WinXP dies in a week, I wish I hadn’t updated. (Glad I had a good backup to roll back to.)

Same here with Win7. Tried several times to update. The update runs, then on reboot, Windows won’t even start - gets part way then stops completely - every time. Managed to restore system with RollbackRX (worth every penny).
Maybe it’s clashing with the Antivirus (only found one other program that did that), but whatever it is, I’ve disabled automatic search for updates, at least until Comodo manage to produce a stable & working update.

Welcome EdwardM.
Hi coyote2 and EdwardM,
Maybe updating from older versions than the more recent is causing some issues.
It is still compatible with XP.

I would consider a clean re-install following the advice in the link below considering update issues have occurred.
Most Effective Way to Reinstall/Update CIS to Avoid/Fix Problems

Kind regards.

Thanks for that heads up coyote2. I intend on keeping 5.12 on my xp systems. I saw your post last night after I noticed my version 6.3 on a vista system auto updating the program, I stopped the update around 80% in hopes to not upgrade 6.3 to 7, but it changed it anyway. I just hope I don’t have an incomplete installation. As far as your XP system, I’m not sure what (hosed) exactly means in your terms ( I take it you mean completely inoperable?), but I’m guessing it may have something to do with the famous [complete uninstall of comodo] {thread} in the forums in order to prevent conflicts when updating.

Hello all, sorry to hear that updates are causing issues on your systems.
For Comodo to be able to fix this they need more details about your system setup.

Would you mind telling us which Antivirus you are running next Comodo, which Comodo version are you running Firewall only ?

Ideally it would be great to have a complete list of processes running on your system(s). (e.g. screenshot of process explorer Process Explorer - Sysinternals | Microsoft Learn)

using FW only, avira AV only and netgear genie on wind 7 64bit
update reboot
one year… desktop loading classic shell menu loading … pc freazing
reboot by power off on
one year… desktop loading, every thing loading, FW crash
diagnosis tool, cant fix error
uninstall FW totaly
PC boot fast desktop load fast internet work perfect
reinstall FV
one year … loading loading loading … al OK… pc slow almost freazing from time to time… or just slow, FW tray not loading but crash
diagnosis tool running… running … running… % % %
FW starting from start menü
Diagnosis tool finish no errors at all
starting, loading slow, FW crash, diagnosis tool, FW start manualy, diagnosis found no error
internet slow, 1 site 15 minutes, every site slow!.. but downloads normal,
turning off site filter in comodo FW
internet normal
now boot slow, internet normal, trust = -100%, sitefilter = trash 100%, new GUI = Trash, Functionality = 0.01%, problem = 99.666%

advice … do not touch a running system! dont update a running comodo product, this company seems to be over its top, from time to time it gets woerse
it was a good time with comodo :smiley:

Yep same problem updating the free firewall v 5.12 yesterday, completely forze windows 7 32 bit at startup.

I am running avast antivirus.

Its lucky I had an acronis image backup of my system, else it would have been a huge headache

For the record I had a second try with the comodo update and same problem, so for the moment I reinstalled my image of windows and staying with comodo free firewall v 5.12.

For all others out there you have been warned, this update has the huge potential to ruin your windows.


Probably problem:
Doesn’t allow to update normally - Avast.
Try to disconnect Avast before the Comodo FW updating.

I updated already FW 2 times from 5.10 to new 7.
No problems.
I have no third-party antiviruses. Only FW.
Also Win 7 32 SP1.

Seems most of these hosed systems are from going v5 to v7. I would recommend manually updating instead.

I did update from 7 version , so the problem is in automatic updating is exist.Please, before making final version available in public - check it very carefully on many systems including, 64 bit…

OK. Tried the clean install method you suggested. 1st time firewall ran for a while, then hung entire system on clicking one of the alerts. After reboot, ran ok for a while, then program wanted to download yet more updates. Did that, & guess what - system hang again.
Wound back using Rollback, and tried again. Very carefully. Used every cleaner I could find. Cold boot, disabled antivirus (Bitdefender), reinstalled, rebooted. Again, ran for a few minutes, then crashed system on clicking an alert.
This is not good at all >:(.

…and i confirm this and repeat this…