Update Failures

I have been seeing update failures with the CIS 4.0 recently. I get the following message from several machines: Updating process failed with error -2147467259 (Unknown error occured.)

  1. What is operation system of computer with CIS?
  2. Was endpoint logged on or logged off?
  3. This error occured once or it is stable reproducible on the same endpoint?

And one more question - can you ping download.comodo.com from CIS machine?

Three machines are XP SP3 the other is W7. Endpoint Logged on and off. I get the error every 10-15 minutes it seems where the CIS is constantly trying to update. I am able to ping download.comodo.com, but I am using the COU. And that CIS is pointing to the COU.

Most probably CIS is not able to connect to COU.

  • Check if COU service is up and running
  • Check that access to COU port is not blocked by firewall
  • Check that CIS update URL points to correct COU IP and port (you have to switch CIS to local mode to do this)
  • Check if ping COU computer is successful from CIS computer

CIS fails in the middle of the update. I tried to update CIS pointing to the Comodo servers and I get the same result.

Have you solved the problem?

I have been out on travel so I haven’t messed with it the past week. I will check Monday and get back with you.



Please tell me if you used the ‘CIS - Set Update Hosts List’ to setup CIS to update from the COU server or 'CIS - Set Update URL? The second is only for CIS 4.0 and older versions.


CIS Host list. With my COU first in the list followed by Comodo update server URL.

Seems that problem not in downloading but in applying AV Db.

Your correct Ratz. I went to the users machine and tried to update the definitions and it failed trying to apply. Where is the definition file kept. I can then take the file from the COU and manually put it in? Would that work with CIS?


Do we speak about CIS 4.0 not about 4.1?
Try to update if this is CIS 4.0.

BTW is CIS not in Red status?

CIS 4.0 on two machines and 4.1 on four machines.


Try to reinstall CIS and see if it helps.