Update causes problem with outmoded theme files


I’m running WinXP SP3 and I downloaded the CIS v5 installer from the forum announcement page. Installation failed as it was unable to remove v4 (some file not found). Then I let v4 do the update as it signalled an available update.

Afterwards, Comodo v5 seems to be running but the GUI interface is messed up:

Perhaps that happens because I had a different skin for v4?

Now I’ giong to reinstall v5 on top of it.

EDIT: I get the same error (error no. 2) and the installer says that it is still unable to remove CIS v4? Will try to identify the skin files.

OK problem solved. After renaming all *.theme files, Comodo crashed on start and left me unprotected (at least it looks like that).
I figured out that it needs at least one *.theme file. Re-renamed cfp.theme and voilà - everything works.

But isn’t that a security risk, if one only has to delete the skin file and on the next reboot CFP crashes??

The upgrade ran automatically, and Comodo seems to be running (the statis bar icon is active), however when I open the application to check all the setttings all I can see is this …

[attachment deleted by admin]

I thought i was the only one with a messed up GUI interface but i didnt have use a different skin for it
I use vista 32 with nod32

i tried it through the update installer and after reboot i got the messed up GUI interface too
tried to uninstall and got an error from c:windows\install\cis_setup but it was not even there but it uninstalled cis. then i tried a clean install but got that error again. so i couldnt install cis 5 so restored my comp with norton ghost.

After that i uninstalled cis 4 without any errors reboot my comp then tried to install cis 5 again everything seems to went well but after reboot i still got the messed up GUI interface so i restored my again with norton ghost.

But maybe it could be the bug to rename the theme can anyone else confirm this.

I use Avira. Interesting, if you didn’t change the skin…

Are you using non standard theme?

You may be interested in CIS 5 Themes ….

I got that problem too and not using a non standard theme only the orginal
but restored my comp back with NG
Will stick with v 4 till the bug is solved.

hi, i’ve got the same problem. i don’t know how to restore comodo to a previous version, can anyone help?
hope this will be resolved

As posted by another member here please remove all non standard CIS 5 themes will force CIS to use the correct one.

Please check you only have one present screenshot.


[attachment deleted by admin]

thank You!! :slight_smile:
works fine now

Hi guys, when I allowed the ‘Update’ of version 5 over 4, I was presented with the outline of the CIS program pane, with vacant area within. (Attachment shows the pane in a word.doc) Three (3) reboots did not solve the problem, so I downloaded the current version of CIS from the website and ran it (without issue). Everything worked well following this action. In version 4 I had used a ‘blue’ colour theme and seem to recall downloading it from a link in the Comodo forums. Whilst I am unsure, I think it was a ‘recommended’ colour theme. Great program, this was a nuisance, not a disaster. Perhaps it might be worth having an area on the website, or in the program to facilitate known colour themes?

[attachment deleted by admin]

There are themes that work with CIS 5 here CIS 5 Themes.


We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


I had never use the themes before and still got The messed up GUI interface today i tried again but i put the themes in v4 before i did the update i did select a theme before i did the update to v5 after the update to v5 i reboot the comp and it worked with the theme i selected but when i tried to put on the default theme from cis i got The messed up GUI interface again and tried everything whats above but that didnt work so restored my comp back with NG again after that i did the whole story once again and it works now with all the non standard theme but not the default theme from commodo isnt that weird???

The appears to deal mainly with non-standard skins, which I guess the updater cannot reasonably be expected to deal with.

I’ll shift this to installation help, so you guys can get the best possible help with this and you can help others. If a bug is discovered any mod will pass it back to bugs again.

Hop this is OK

Best wishes


I’ve tried playing around with the theme files as sugested above, even deleting them but makes no difference for me.
Also tried out putting the CIS 5 themes in the themes folder but nothing works.

Have you tried restoring the original theme before you upgraded? Then use the v5 themes?
Maybe this is why some upgrades are failing?

I never changed themes in version 4 (didn’t know you could) so when I upgraded, presumably V4 would have been using the default theme.
It worked fine on my laptop.
I even tried uninstalling V4 and doin V5 as a new install but still the same problem.

I’ve just a total uninstall of V5, made sure all the program files have been deleted and then done a fresh install rather than an update and the console screen is now working fine.

здравствуйте, у меня не обновляется антивирус, на 5 % вылазит ошибка, что мне делать ??? ??? ??? ??? ??? ??? :cry: