Unistalling/Installing blunder

Yesterday I was having problems with the popups that notify when something is being blocked and such stopped showing. This caused any new program I ran to hang until I disabled Defense+. Wanting to try a reinstall before I had to come for advice on this problem I did uninstall, however I had a moment of idiocy and also ran the installer before I restarted my computer.

When my computer restated I received a popup saying “Error: Error while loading resources from C:/Program Files/COMODO/COMODO internet security/cfp.dll. Aborting application.” I tried to run the installer again and it notified me that I seem to have COMODO installed, trying to remove the parts from the installer fails (the installer just exits). I tried to uninstall it again but all it said was that it was already uninstalled, clicking on the shortcut tells me that there is nothing the shortcut is supposed to target. While I’m not sure if this is directly connected after this happened my laptop (Which all this occurred on) can no longer connect to the internet, It connects to the wireless signal but with limited access while my devices connect fine.

Thank you for reading this I hope that you can help me with my problem.

I managed to fix my problem after rummaging through the forums and finding a guide on removing COMODO by hand. The Internet blockage was caused by a driver and now everything seems to be ok.

What driver was blocking the internet access?