Uninstalling CIS or Firewall breaks internet connection.

I have been having this weird problem, when uninstalling CIS or firewall, it breaks the internet connection, happens on W8 and W10. Tried comodo uninstall tool also.

Tried windows own network problem solving, reseted the network connections (W!0) tried resetting the winsock and many other things that google suggested, still in ethernet and and wifi, it saus connected and protected, but no internet access, windows gives random errors about dns, netvork adapter and ip address. Tried editing the registry, you name it,propably tried it.

tried even reinstalling network adapters, after fiddling a day with no success, only thing that helped was clean install of windows.

Have tried unchecking the Comodo Internet Security Firewall Driver in the Adapter settings?

How did you uninstall CIS? Did you use uninstall from apps & features or control panel programs and features? Or did you use some 3rd party uninstaller tool?

Nope, as it doesn’t show up either ethernet or the wifi :frowning: the uninstaller seems to uninstall cis or firewall, but it brokes some networking component.

Uninstalled from add or remove programs, rebooted and no internet.

Sometimes it happens that you can’t connect to the internet after uninstalling, using the unofficial clean up tool or trying a manual deinstallation. Then the Inspect driver is still present and needs to be uninstalled.

How to uninstall the CIS firewall driver when it stays present? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.