Uninstalled AV Portion, Now CCE Won't Load [v6] [M275]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?:I can reproduce the problem every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:To reproduce this install CIS. Then, open CCE, causing it to be downloaded and installed. Then, after everything is restarted and working fine uninstall only the AV component of CIS. Then, after restarting, try to open CIS. You will get an error message that CCE could not load (Screenshot attached).
  • If not obvious, what U expected to happen: I would have expected that CCE would still work, or at least would have the ability to be redownloaded, as I only uninstalled the AV component.
  • If a software compatibility problem have U tried the conflict FAQ?: NA
  • Any software except CIS/OS involved? No
  • Any other information, eg your guess at the cause, how U tried to fix it etc: This may be caused because when the AV component is removed it also removes an important file for CCE. Also, note that if the AV portion is installed again CCE once again is able to work.

Also, I’d like to mention that this was brought to my attention through clocks, who described the problem in this topic. Thus, this has already been replicated by two users.

  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware) Screenshot and the diagnostics report (which found no errors) are attached. I cannot attach a KillSwitch process list as it is CCE itself that is not able to start.

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- CIS version & configuration: CIS 6.0.264710.2708 to CF 6.0.264710.2708. The configuration is not important for this bug.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: NA for this bug.
  • Have U made any other changes to the default config? (egs here.): NA for this bug.
  • Have U updated (without uninstall) from a previous version of CIS: No, it was a clean reinstall.
    [li]if so, have U tried a a clean reinstall - if not please do?: NA
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: NA
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: Windows 7 x64 (Service Pack 1), UAC is disabled, administrator account, not a virtual machine.
  • Other security/sandbox software a) currently installed b) installed since OS: a=None b=none

[attachment deleted by admin]

I have the same issue. thanks

Hi Chiron

Good. report. Yes if this is to be the result it should tell you when you uninstall.

Could you append you process list please?

Best wishes


As mentioned in the report, I could append the KillSwitch processes, but that would not tell me anything as I can only append those once I reinstall the AV component, thus re-enabling CCE. However, the issue is what happens once CCE does not work. Thus, I can’t append the KillSwitch process list as when the issue is occurring it is CCE itself that does not work.

Sorry Chiron, missed that bit, will forward tomorrow

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Hi Chiron,
I am sorry for reply late.
The problem you reported is not a bug, CCE need AV’s component. If uninsall AV component, the CCE will failed to works.

Thanks for the feedback,
Best Regards

If this is how CCE works now then how is it working correctly on my system, im only using the firewall and defense +. The Av was never installed

Hi wasgij6,
The standalone (portable) version of CCE runs fine without any other component installed.
But on my system the version integrated with CIS it is the same as Chiron.
Once the AV component is removed CCE fails to load from within CIS (Screenshot).

[attachment deleted by admin]

I didnt run the portable version i clicked clean endpoint from the GUI (integrated in CIS) and it ran correctly without the AV component installed. it seems like the only time it gives an error is when you had the AV installed then removed it. In my case i never had it installed and it works correctly

Thanks wasgij6,
This does appear very likely to be the common factor.
If I get around to it later I will do an uninstall/re-install without the AV component and see if I get the same results.

I did a clean install with the FW component only and CCE loads correctly.
I added the AV component and CCE loads correctly.
I removed the AV component and CCE loads correctly.

I did another clean install with both the AV/FW components together and CCE loads correctly.
I removed the AV component and CCE failed to load.
I added the AV component and CCE loads correctly.

It appears to be when both components are initially installed together and then the AV component is removed, then the issue arises.
I have not tried this the other way by removing the FW component from a full install.

I cannot for the life of me work out why, but that is what I found.

Thanks for testing this out captainsticks

This is definitely a weird bug and needs to be looked at.

Here’s the criteria I use to distinguish a reportable issue from a wish-list item:

Personally I think this report falls well within the definition. Of course devs may know the behavior we are looking for is not actually mentioned in the actual design spec. But really all that matters is whether this needs fixing. Or, if you like, should it have been in the design spec?

Would it be possible for you to reconsider, Flykite, given the additional information posted above?

Best wishes


I’m sorry that my previous reply is not correct.
If AV component installed, CCE will works and use AV’s engine & Virus DB.
If there is no AV component, CCE should works too and use it’s own engine & Virus DB.

So, CCE will failed to start after AV component uninstalled is a bug, we will fix it in next version.

Best Regards.

Thanks Flykite and to the other Moderators. :-TU

Thank you.


Thanks Flykite :slight_smile:

This is fixed with version 6.1.275152.2801.