Uninstall failed + MSI Installer Problems


I installed Comodo AV a few days ago and couldn’t send emails from Outlook after that (even when email scanning was disabled) , virus scan was slow and CPU consuming so I decided to uninstall it.
Automatic uninstall failed (from ‘Add Remove Programs’) so I tried manual uninstall - after which MSI tries to install something every time I open Explorer or try to manage my computer. I have this message in Windows event log: Detection of product ‘{6617B209-C45E-4ED7-86A6-5055D17BFBEE}’, feature ‘DefaultFeature’ failed during request for component ‘{E79E3ED7-50A7-49F7-8C11-EF43F5650180}’

I followed every step described in some of the previous posts:

  • Ran script from 'uninstall CAV.zip ’
  • Ran app from ‘Remove Registry entry after manual uninstall.zip’ (Failed)
  • Used SafeMSI, HijackThis, ServiWin, HijackThis, Dial-a-fix-v0.60.0.24, Spybot Search&Destroy, Norton’s WinDoctor
  • Manually searched registry for all entries with ‘comodo’ and deleted them
  • Searched file system for all files created during installation time frame and deleted them (if had something to do with Comodo)
  • Reinstalled MSI
  • Tried to do system restore with restore point created prior to Comodo installation

Still, MSI popups and tries to install something leaving those entries in the log. Two mentioned GUID’s are nowhere to be found in registry or file system.

You Comodo guys better have some solution for this!!! Never seen any decent (free or not) application behaving in such a way.

Hello paitl,
You are getting this popup because of improper un-installation of CAV.
According to MSI architecture service will keep monitoring on those components which are registered in that machine .if you missed any of entry during un-installation probably you will get this problem. So what you have to do is, a clean un-installation, right now you can’t use normal un-installation method( running cav un-installer from Add-Remove programs).

I suggest you to visit this link and listen what Microsoft says if such situation occurs.
Try with Windows Installer CleanUp Utility.

(CLY) (L)

Frank, any other suggestions? I did the Windows Cleanup Utility some time back, after searching thru MS’s website. It did nothing for me, since it can’t recognize that CAVS 1.x Beta is on the computer. I was able to find 8 references to the Product GUID in the registry, and removed them, but that did nothing either (I’ve done what Paitl’s done, and more), although it has worked for some.



Check your Installer directories (listed below) for those missing GUIDs. This is where MSI is looking & detecting the missing products from.

C:\Program Files\InstallShield Installation Information

hi kail,
That move is bit risky, if you modify that protected directory(it is hidden from windows explorer) may be your system will not boot for the next time, the pop-up MSI installer will come and will go in sudden. But it depends on many facts, like installed other packages which are sharing the same component. That means any of your startup objects required the same component it will keep trying to install the missing component.
Hope I can find a solution for this, now I am working on it, I will come up with a solution.

Frank, I await your solution eagerly. (:WAV) With the frequent MSI popup occuring, it seems like there’s an “In Progress” install entry triggering, which would be consistent with the symptoms . However, I’ve searched thru all the registry paths that msizap would follow, and no trace of those GUIDs. Maybe there’s somewhere else…

BTW, my process is Here (regarding removal of Beta1.x so as to install Beta2.x) and here (regarding the continuing MSI popup ever since the System Restore following the initial removal of Beta1.x)

When I initially uninstalled Beta1.x, I didn’t have any problems, and wouldn’t have Restored if I hadn’t encountered the explorer.exe problem after installing Beta2.x. My thought/instinct is that when Restore initiated the reinstall of Beta1.x, something went wrong with that reinstall, and thus with the attempted uninstall.

Once again, looking forward to your solution!