Unable to UPnP port-How to rectify this?

I installed Comodo today and I should say it is an amazing product. I am going to tell all my friends in my school about this firewall. Thanks a lot Comodo.
I have a small setting to be adjusted but do not know how. The problem is this.
When I have my Comodo in the custom mode and when I start utorrent ( Bittorrent Client ) I find this message in the logger-“Unable to map UPnP port”. I had this problem when I was using ZoneAlarm. Then I used to turn off the firewall to make it work correctly. I am doing a similar thing with Comodo. I make the setting “Allow All” to start of utorrent until it works properly. Once it works fine I change the setting to custom and then I do not have problems. I have already opened ports using Comodo and I am using these ports for utorrent. I think Comodo opens port of TCP/UDP type but not UPnP. I do not face this problem with Azureus because it uses TCP/UDP ports. I think there is a different way to open a UPnP port for applications like this. Hope I could get some help.
Thank you again for a wonderful product,

You should turn off UPnP in uTorrent when you use CFP.
There have been some issues if you have it on in uTorrent.
Let us know how it goes.

Well I tried that too. I was just going through those issues and tutorial by pandlouk but did not work. I unchecked “Enable UPnP port” and “Randomize Port”. I also saw the screenshots and also set my settings but for no change. Is this a bug. I found similar problems with ZA Pro too.

Good News!!!
I got out of it. Simple!!! I just used the following settings for Network Monitor.
Permission: Allow
Protocol: TCP/UDP In
Source IP: Any
Destination IP: Any
Source port: Any
Destination Port: Any

Not just that. I also checked “Enable UPnP” and it showed no problem. The icon turned green too. Thanks for your support AOwL. Could you please tell me with the above setting do I have any security threats? This could answer all the problems and issues with utorrent and Comodo Firewall.

That rule will leave you wide open! It’s almost the opposite of the default final block all rule. uTorrent only uses one listening port, so you should update that rule to specify the Destination Port from Any to the one you assigned it.

As soyabeaner said, this rule makes you very vulnerable. Please restore the original rules.

To make utorrent work, you have to define a dedicated port for it. You can do that in utorrent’s Preferences. You should also disable UPnP.

The next step is adding a network rule above all the other rules (since they are executed from top to bottom):

Action: Allow
Protocol: TCP/UDP
Direction: In
Source: Any
Destination: Any or Zone
Destination port: A Single port (the one you’ve set in the utorrent preferences)

To work, utorrent must be allowed TCP/UDP in and out. You can check this in Application monitor.

Run Define a new trusted network wizzard, if you haven’t allready done it.

Hope this helps…

Like Soyabeaner say, remove that rule you made.
Do you have the default rules, except for the ones you have tried to make yourself?

That enble UPnP is mostly for WinXP built in firewall and some routers, to let P2P traffic through automatically. CFP doesn’t have that function.
You should keep it disabled.
Follow my guide here and do exactly as I write.
If it doesn’t work, you should post a screenshot of your network monitor rules in full view, and save your log while you try to use uTorrent, by going to the log (activities/logs) and right click and export as html. You can attach your files by clicking “additional options” when you post.

First you need to go in to your settings in uTorrent.
Uncheck the “use random ports” option.
Uncheck the “enable UPnP” option.
Set the port you would like to use. Lets say that we use port 54789.
Now, save your settings and close uTorrent.

Open the firewall (double click the sys tray icon).

Network monitor works like a router, so you have to “forward” port(s),
like you do in a router, for apps like Torrent/P2P.

Go to Network monitor (security/network monitor).
Right click on your block rule and add/add before.
Do these settings.

Action : Allow
Protocol : TCP or UDP
Direction : In
Source IP : Any
Destination IP : Any (or zone if you have one)
Source Port : Any
Destination Port : A single port : 54789

Click OK.
Start uTorrent and give it a few minutes before you think it doesn’t work.

If it doesn’t seem to work, restart CF or reboot your PC.

Always remember to place your allow rules you make, above the default block rule.
Network monitor reads the rules from the top to the bottom.

Also check the log in activity/logs and try to see which rule that blocks your app.

EDIT: Bubu74 has already posted the same answer I see… ;D
I will post this anyway… :wink:

Good thing that you did, your answer if far more detailed than mine ;D.
I think we should make a FAQ for utorrent… But that’s offtopic…

Hey friends,
Thanks for your support. I observed a few things with utorrent today. If we have UPnP enabled then utorrent uses another port in random to contact your router/modem. Now this port will change every time we restart the router. So all the problems with mapping of UPnP port is because of this particular port. This port is usually in the range of 2000 to 3000 for me. So narrowing the port range is the solution. That is as we have already discussed about opening a single port using firewall but the port to map the UPnP port is closed by the firewall. So after the single port is opened we should make another rule in the Network Monitor with the rules being the same as opening a single port except that the destination port being a range of ports depending on the router/modem. For me it is 2000-3000. By trial and error method we can narrow the port range. Do not forget UPnP must be enabled and no need of restarting the system.
I hope this solves the problems of utorrent. So if anyone has something to tell me like security threats or risks or problems please tell me so that even I could learn.
Thank you

I don’t think it is a good idea to open such a wide port range.

Does the utorrent work with the UPnp disabled? If it doesn’t, you should do the port forwarding in your router (the same port number you’ve opened for utorrent in CFP).

If you are not sure how to do this, there are some guides on this site: How To Set Up Port Forwarding - Port Forward. You should also check in your router manual.

I agree with Bubu74.
It works like in my guide in a previous post, but i didn’t mention that you should open a port in your router.
Go to portforward.com instead and see how you open a port in your router.

Ok I got it. Opening so many number of ports is not good but it may opened until it turns green. That is Allow this rule until the icon turns green and once it turns green just Block the rule. This works for sure with UPnP enabled. But this is not the solution for it. Anyway I will try your method too and come back.
Thank you

I’ve downloaded utorrent and done some testings. Here are my conclusions:

There are two ways to make utorrent work behind a NAT router/ Comodo Firewall

1st way:

  • do a Port Forwarding in your router settings
  • open the same port in CFP for UDP/TCP in
  • in utorrent disable UPnP and Randomize port; set the port number you’ve opened

2nd way:

  • do a Port Triggering in your router settings
  • open the same port in CFP for UDP/TCP in
  • in utorrent enable UPnP and disable Randomize port; set the port number you’ve opened

Both ways works for me :slight_smile:

Thanks for testing Bubu74!
I have just tried the first way, and it’s no problem with that.
Don’t sit there and download any illegal stuff all night now… :wink:

Nice to hear that :slight_smile:

:smiley: I’ll try to resist!

Thanks Bubu,
The first one worked for me. Thanks a lot. The problem with me was I didnot know how to forward ports in the router. Mine is a different router. Anyway thanks a lot. (L)

You welcome!