Unable to uninstall completely my CIS

I uninstalled my free CIS because an error appeared every time I wanted to scan the computer. When I tried to reinstall it with (CIS_Setup_3.10.102363.531_XP_Vista_x64.exe) it suggested that I uninstall or add/remove. When I click yes nothing happens.

I checked for any Comodo to uninstall but there was none in add/remove program in the control panel. Now I can no longer reinstall Comodo. My O/S is Vista Home Premium 64 bit. What should I do?

Hello joemoshi

Can you open a command-box and go to the following folder (assuming default install)
c:\program files\comodo\comodo internet security\

Type cfpconfg -u

And press enter after that, this should bring up the add/remove wizard.

Hi Ronny,

I am afraid I do not know what you mean by “open a command-box”. In any case I found a file folder under program files called COMODO. In this folder there are some 15 files of dll, exe and dat cat but not cfpconfg -u. All other files have been deleted.

I sent these 15 files to the recycling bin and tried again to no avail. Now I restored them.

What I need to do is to remove anything that gives the installer the impression that Comodo is installed.



I have been using various comodo products on my client systems but recently I tried to install comodo internet security suite x64 on my clients windows server. The installation went well but I’ve been locked out of the server and the only way I can access it is using SAC. I’ve been able to access the cmd prompt of the server but there’s no network connection at all - Firewall seems to be in Block everything mode. I would need your assistance in order to find out the exact files entries or switches that I can use on the server from command prompt - I tried to use wmic and msiexec to remove the firewall completely but have not been successful. Along with this, I tried to run cfpconfg.exe -u in order to uninstall it but doesn’t seem to work from ‘cmd’ too. I would really appreciate if I can receive some response on this ticket as soon as possible as I intent to purchase and deploy Comodo Firewall Pro on client servers if this issue gets resolved.

Best Regards,


This sounds like a bunch of manual editing, there is a “Clean up script” but that’s for x32 bit versions, I’m not sure if that will work on 64 bit because of different file paths and filenames like guard32.dll and guard64.dll etc

You could try to download the script and check all entries manually but that will take some knowledge of the windows registry… please let me know if you do or do not, i’ll see if i can rig up a 64 bit test set and edit the script accordingly…

Hi Sim,

What’s the Server OS version you are running ?
And normally you should be able to boot in to safe-mode an uninstall, CIS is not active in safe-mode so it should not give you trouble there…

Could it be conflicting with other security software and or restrictive policies on the machine ?

Thank you Ronny,

I am afraid I do not know where to start to try to download the script let alone rigging up a 64 bit test. Thanks

Get the script here: https://forums.comodo.com/install_setup_configuration_help/cleanup_tool_for_comodo_internet_security-t36499.0.html;msg259617#msg259617 .

Or when you want to go manual (forget about the Legacy keys as they are too much work):

Uninstall CIS and reboot. Then run [url=http://system-cleaner.comodo.com/]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See: https://forums.comodo.com/help_for_v3/comprehensive_instructions_for_completely_removing_comodo_firewall_pro_info-t17220.0.html;msg119226#msg119226

Now you should be good to go

Thank you EricJH,

I downloaded the Comodo System Cleaner and performed a power clean. Needless to say it removed many of the registries and all the cookies. After that the computer no longer functioned and I had to restore to a previous date. Now I am busy reinstalling my cookies and other items. Once I do that I start deleting folder as per your instructions. Thanks

You are looking for the wrong thing.
There is no such thing as “cfpconfg -u”. They are two different words separated by a space
The first word is a command that is obeyed by a file called cfpconfig.???
and the second word is an argument that tells it what to do.
There should be TWO cfpconfg files called cfpconfg.dll and cfpconfg.exe

You should “open a command-box”,
which means click on “Start” (bottom left corner) then click on “Run…” then type in the box “CMD” and click O.K.
That gives you a black “command-box” which accepts DOS commands.
Type the following line and then hit the keyboard ENTER.
CD /D \Program Files\COMODO\COMODO Internet Security
You would have seen a response
C:\Program Files\COMODO\COMODO Internet Security>
To that you should append the command “cfpconfg -u”, so the screen shows
C:\Program Files\COMODO\COMODO Internet Security>cfpconfg -u
When the screen shows that, hit Keyboard ENTER and it would have been uninstalled.

That is how it should have been.
You MAY be lucky if you try that now, it all depends upon what partial removals you have accomplished since you were first given that advice.
e.g. it will no longer work if the relevant cfpconfg file has gone.
(I guess it requires the cfpconfg.exe, and possibly the cfpconfg.dll, but undelete may also require other files and folders).


Thank you Alan,

You are right: I no longer have any cfpconfg files. I tried to install Comodo again but it indicated that I should uninstall first. It is a catch 22. I guess now I am banned from using Comodo Internet Security forever.

What is the possibility of importing the cfpconfg.exe and cfpconfg.dll? Could this help?

Did you try the manual clean up or the script?

There is sometimes another way to get rid of the uninstall warning. Download good ol’ Regcleaner and remove all keys pointing to Comodo Internet Security. When this doesn’t help I recommend to do the manual clean up.

I did a regedit and removed all files with comodo (I think, may be more) and then I was able to install Comodo. However when the installation was completed and the computer was restarted the computer no longer worked. I had to restore.

If you are lucky then System Restore may offer the chance to revert to the old system with the old Comodo.

If you are very lucky it might be successful and then you can try again to remove the old and install the new.


[b]Sim /b,

if you cannot remove CIS completely because it is blocking any action, here is what can help (filenames and paths may be different for x64 server machine, i provide what i have on XP x32 desktop machine):

  • get access to server when it is offline, e.g. with a help of LiveCD;
  • rename CIS drivers named cmdguard.sys and inspect.sys to drivername.sys.tmpp (or similar); drivers are located under %windir%\system32\drivers\ ;
  • boot server and uninstall CIS ;

if none actions are blocked and you just want instructions how to uninstall CIS from commandline, then i’m of no help.

In case of need you can also boot in Safe Mode and start the client. Then take out all block rules you made.

Another strategy in Safe Mode would be to import a back up configuration from the Comodo installation folder; give it a new name and activate it.

I went to Regedit again and deleted only the Registries with Comodo. I was then able to install Comodo. However when restarting, the computer froze and I had to restart again in safe mode and uninstall Comodo.

Now that Comodo was uninstalled properly I reistalled it again. But alas the computer froze again on start up. So I uninstalled Comodo again.

This is one heck of a persistent problem…

Do you have other security program running in the background? Try disabling them. Also try the following.

We are gonna take a look to see if there are some old drivers of your previous security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> do this for all drivers → reboot your computer.

When the problem persists make sure there are noauto starts from your previous security programs download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

I hope this helps.

I disabled the other security programs, restarted, installed Comodo and restarted. The computer froze on startup. I looked at the device manager non plug and play and there is AVG and Outpost firewall drivers (the two programs I am presently using to replace Comodo). I am concerned if I uninstall these drivers I shall be in a bigger mess.

I think I will go on vacation from Comodo for now and try what you suggested another day. Your help is very much appreciated. Thanks.

When you don’t have Outpost or AVG installed anymore these are very likely the drivers that interfere.

When you are using AVG as your AV program you leave these drivers alone of course. When you use AVG for your firewall change its installation to AV only. But the Outpost drivers need to go as two firewalls can do all sorts of weird things.