Unable to install required packages

When trying to install COMODO Cleaning Essentials from the GUI (Tasks>Advanced Tasks>Clean Endpoint) I get the message Cannot install. Error: 5 Access denied.
Same thing happens with installing Killswitch (Tasks>Containment Tasks>View Active Processes and then clicking MORE in the next window). Same error.

I’ve read in another post that it is a side effect of not allowing network access to CIS processes, but since it is an integral feature of the GUI I am wondering if there is a work around. I am running CIS as administrator and have tried disabling the AV and Firewall. HIPS is disabled by default.

Version beta and stable fixed try :Comodo Forum

Add quote in file host > ‪C:\Windows\System32\drivers\etc\hosts download.comodo.com www.download.comodo.com

Thanks for your help. This worked in the sense that it allowed me to install Killswitch, but I am running into a new problem. The Clean Endpoint (CCE) and Watch Activity (Killswitch) buttons don’t work, neither does the MORE button under the Active Processes list. Nothing happens.

I think I am going to give it a rest. I will use the stand alone versions when needed.

Last question: Will the program update normally now that I have a beta version installed?

I couldn’t let it go… I used the uninstall method in one of the sticky posts, and reinstalled the beta. It all works now!

In the process I kind of answered my own question. I don’t think the program updates normally. To even use the uninstall tool I had to revert the hosts file back to it’s previous state.

Will the beta update automatically?