Unable to find network printer COMODO Firewall Officejet Pro 8500A - SOLVED

I fought this for a few days - posting this to save others some time.

Officejet Pro 8500A - the printer’s software and utilities as well as the hp home diagnostics utility could not find the network printer in both wired and wireless configurations. I could however ping the printer and access the printer’s web gui.

Per the FAQ I disabled all non windows services, exited out of the Comodo firewall and disabled Microsoft Security Essentials but still had the same issue.

Comodo Firewall has an option to block fragmented IP datagrams. It is located in Firewall → Firewall Behavior Settings → Advanced. THIS MUST BE DISABLED.

I exited out of Comodo by right clicking on the icon in the notification area then selecting exit and replying Yes to the verification prompt.
The Comodo executable, cfp.exe, was not listed as a running process in the windows task manager.
It appears that some left over part of Comodo was still blocking fragmented IP datagrams.

Once I disabled this option in Comodo, the printer could now be found regardless of whether Comodo is running or not.

Hi there,

you are my hero ;). I was searching the hole web for this solution. I have the same printer and i did almost all, but nothing worked for me. And then YOU come with this little, but powerfull post.
Thanks a lot! :-TU :-TU :-TU :-TU :-TU

A guy from germany

FYI - this same configuration change is also required to allow most NAS’s to be accessible from a CIS protected system.

Thanks for the fix… having to disable the FW everytime I wanted to print or scan was becoming tedious.

Just out of curiosity, what vulnerabilities (if any) are created when disabling block fragmented IP datagrams?

hey and warm welcome Version 7, thesquare & FrnchDp

do you know what your printer has for ip address? to see what your printer have for ip go to Start → run → cmd. Here you write ipconfig /all

when you have found the ip go to CIS → firewall → Stealth wizard guide → Define a new trusted network… → I would like to define and trust a new network zone.

Valentin N

Unchecking the fragmented IP datagrams was the fix for my 8600 also.
Thanks to the original poster for taking the time to share this! :-TU