Unable to create rescue disk


Windows 10 OS Build 19043.1023 / 21H1 (Preview)

When attempting to create a rescue disk it immediately complains of a corrupt package. But it’s actually downloading the package in the background. That download stops at 98%. If I try again the same thing happens - it doesn’t resume the download, but just starts over and again stops at 98%. The error dialog pops up immediately, before or right when it starts the download.
Edit: I got it to try to install, with the error dialog in front, but it stopped at 49% that time.

try download via browser: https://cdn.download.comodo.com/crd/download/setups/comodo_rescue_disk_2.0.261647.1.iso

The one downloaded through CIS is older than the standalone version which you can download here: http://download.comodo.com/crd/download/setups/comodo_rescue_disk_2.0.275239.1.iso

That got me further - thanks! Now I get to Writing Files, with a Disk Write Error at 88%. I tried 3 different USB sticks, single FAT32 partition, with the same problem at the same point. So it’s probably where it starts blocking pending actual device writes. I did have to reformat the sticks myself first.

Edit: the specific message is “Rescue disk writing error.” The drives are USB A while this laptop only has thunderbolt, so I’ve tried two different adapters and a hub (USB 3.1, USB C connector to 4xA). The problem persists. The drives all format fine, so are definitely writeable by Explorer.

Hi All,

The “unable to create rescue disk” issue is fixed, kindly check and give us your feedback.