Ultradefrag bypass CIS during the installation ?

I use CIS 5.3…1237: Sandbox disabled, Defense+ in Paranoid Mode at highest level. I make a test: I launch Ultradefrag.exe ( http://ultradefrag.sourceforge.net/ ): Defense+ alerts me with the first pop up, I set " "; Defense give to me others pop ups, I always answer " block always "; but then I see this:

ImageShack - Best place for all of your image hosting and image sharing needs : I push " ignore " and Ultradefrag completes his installation, while Defense+ keeps silent. Why ?

In what folder are you installing Ultra Defrag?

C - Programs. The strange is that I tried with a lot of other programs and Defense+ worked fine with all them. Anyway, after the installation, if I launch Ultradefrag, Defense correctly alerts me and asks about it.

That’s not the safest set-up at all :slight_smile: , setting CIS to paranoid mode ,withouth switching to procative security configuration, would be useless if you asked me.,…

Try swtiching it to proactive security mode and when a pop-up comes up click on " advanced options " and choose block or allow accordingly.

C:\Programs is not a protected folder. That’s why it is not picked up.

%Program Files%, typically c:\Program Files, is a protected folder.

Sorry, I have to correct my previous post: Ultradefrag IS in c:\Program Files; anyway I can’t understand because it’s the only software that seems to bypass some Defense+ control.

I stand corrected. %Program Files% was a protected folder in older versions.

What version of Ultradefrag are you installing? Do you have a url so I can download it to test it here?

Sure, I only corrected my previous post, not your. The version I tried is the 4.4.0 ( UltraDefrag - Browse /ultradefrag/ultradefrag-4.4.0 at SourceForge.net ).Thanks for your help. :slight_smile:

I installed and uninstalled Ultra Defrag various times. Only the first time I installed it behaved like you described. Other times I had to consent for each step as it gets installed in :\Windows\ folder.

Not sure why it behaved like that the firs time. It had done an online look up according to the D+ logs and it was found safe.

On a sidenote. I am using a mod preview of v5.4; not v5.3.

ooo 5.4 when did the mods get that?
does it seem like its close to ready for public release

We got it yesterday. When we get a maintenance update version like this, think several weeks until it goes final.

so im assuming 5.4 is bug fixes mostly. anything new in 5.4

Thanks for your help. I too believed that in some way Defense had found it safe during my installation tests.

Nothing new. Just bug fixes.

well thats good to hear comodo needed to work on bug fixes