Ubuntu 12.04 Comodo Filesystem Filter Driver

OS: Ubuntu 12.04 LTS
Comodo Version: 1.1.268025.1
Virus Signature Database Version: 17714

After Installation of Comodo I get the message “Filesystem filter driver is not loaded!”. I click Run Diagnostics and give root permission. The photo attached is the message I get. I do what it says in a root terminal. Once I’m done I get the same message. I try again a few more times and still no luck. Please help me! :frowning:

[attachment deleted by admin]

Another user of Comodo has had the same problem and has also gotten no answers.

What kernel version are you using? If it is above 3.5 (for instance if you downloaded the latest 12.04.3 I believe) then CAVL will not work without an (unofficial)driver patch.

For those having trouble with Installing and configuring Comodo AV for Linux
Make sure you have the right distro(Ubuntu or Mint) and the right Arc (32 or 64 Bit)

Run ‘/opt/COMODO/post_setup.sh’(As Root sudo)
You will get a File system driver not installed.
You will need this driver http://http://www.bondoffamily-net.com/~kinta-chan/techknow/Linux/RedirFS/src/driver.tar
Now Move that file you downloaded To /opt/COMODO/ as root.
Replacing the old driver!!

You can do this by opening a terminal, type in:

gksudo nautilus

You will be asked for your password, then a GUI interface opens that is actually a root user file manger. Copy the downloaded file and paste it into:


replacing the tar file.

And Then run the code below again

sudo /opt/COMODO/post_setup.sh

This should solve the problem

Link is not formatted right. It should be http://www.bondoffamily-net.com/~kinta-chan/techknow/Linux/RedirFS/src/driver.tar and does this patch only work on debian-based distros? I am running Opensuse (RPM based)and am also getting the same error, but I am using a newer kernel than 3.5. I really don’t want to have to use an older distro in Opensuse. in fact I have grown to like Opensuse better.

Please don’t recommend people replace driver code (which will be inserted into the running kernel) from a totally unknown source, as it is very bad practice at best, foolhardy at worst.

I don’t get why people would be so keen on security that they’d install anti-virus for Linux, but then ruin it all by installing code from just anywhere. The mind boggles. 88)

Was having the same problem but was leery about downloading an unofficial patch so downloaded the 4 Eicar tests and reran the system scan and it picked up all four of them. Kudos to the Comodo team! So as long as it works I’ll take Gold-finger’s advice and stay away from anything that doesn’t come from the Comodo team! Sooooo…Who cares if it says the file system filter driver is not loaded…if it ain’t broke don’t fix it!!

P.S. No offence kinta I’m sure it works great

hi ScribDude, I noticed your reply to this issue and I am experiencing the same problem. You mentioned “downloaded the 4 Eicar tests and reran the system scan and it picked up all four of them.”

I have just installed Lubuntu 14.04 on my old laptop Compaq nx6125 and I am experiencing exactly the same problem.

Can you explain to me how you did this so i can have a go myself. I’m a newbie to linux so if you could explain step-by-step I can follow your method. I can use a terminal window but need the correct syntax as I’m still learning how to use linux.

Any help would be appreciated



NOTE: I’m not sure best practice on these forums, should I create a new post with my issue or is it ok to ask questions on this post? Thanks for any help advise.

hi UBuntuUser

the help for your problem:

you can find here:


Here I have written the steps, which Users of Ubuntu or even ubuntu-based Systems have to take to install COMODO AntiVirus properly and what you have to do, if COMODO stopps working, when a fresh Ubuntukernel arrives.

Ubuntuexpert :slight_smile:

I am working with Ubuntu and ubuntu-based systems since years already.