Trying to update to latest version

Comodo is being a pain. >:( I have version and I tried to install to the latest version. So i downloaded the latest version, uninstalled comodo and rebooted. After rebooting I went to install the latest version. Comodo installed but it is the same version? What happended? I did download the latest version. Also the view active connections is does not work now. I have no idea, I tried to update with autoupdate and all it does it nothing. Tells me to reboot and still tells me there are updates. Keep this up and I will have to look elsewhere.


Search Google for a program called Revo Uninstaller this will completely remove Comodo don’t restart when Comodo says to wait till Revo Uninstall is finished then do an install.

Use Revo in Advanced mode.

I had a similar problem where it would say that I had an earlier version even after I told it to install the updates… Let me ask you… are you using windows vista? If so I found that running COMODO in ‘administrator’ mode after downloading the updates brought it up to the latest. All installations in vista require admin access… which COMODO does not ask for when it updates,… Next time you have it running properly try that…

Ok, I have tried that and that didn’t work either. I used the Revo Uninstaller and when I installed Comodo it came right back whit the same version. I run everything with admin privileges I am running windows Vista. I am getting tired of all the problems, what good is a firewall if you can’t update it? Looks like I am going to have to go with something like Norton or Mcafee.


Ok another problem. I just did a system restore. Comodo was working fine and the version number would come up. Now the version number is blank!. I am trying to do a auto update to see if that fixes the problems. Is this a problem with Comodo or Vista? Wish I never saw vista!! I really hate Microsoft products!!


Sorry to be so negative, I finally got comodo upgraded and working!! Just seems like I am always running into problems every time I go to do something. I told windows to give Comodo admin privileges and this time it worked like a champ.
Thanks to all who posted comments and solutions.
Again sorry to be so negative, just need more patience thats all.