TrustConnect Service *FREE 7-DAY TRIAL*

Hello, Everyone

Okay, problem I am facing here is this I’ve installed this on my Windows 7 and Ubuntu PCs it works on the Windows 7, I have not tried it on the Ubuntu yet, not sure I want to. I did this to use it with my iPhone, but as of yet no joy at all trying this out. I have changed my Service Password rebooted the iPhone still not connecting. I do not care if Windows works, or Ubuntu I would just like this to work with the phone has anyone at all been able to get it going.


Hello Nazar;

Have You Followed This?


Hello, Jacob

First thanks, and yes that was the first thing I had a look at before trying any of this. Here is the error I get each and every time I try to use it on the iPhone, this does not happen on the Windows 7 PC? I just don’t get why it doesn’t work with the phone which is why I wanted to try this.

Error: VPN Connection Authentication failed.

Yes I am using the log-in password and user name. No I am not trying to use the Service Password, and by the way what is the need, for this Service Password? Of yet to use it I don’t get that one.


Just a question; are you using trustconnect on your pc while trying to use it on your iphone?
(I believe you can’t have two log-ins at the same time )

You are trying to use ‘’ as the Server?
If not, then try to use this;

Hope this helps


Nope I installed it on the Windows 7 PC and was able to connect without any problems at all. Once I seen yes this does work I shut down the PC and tried the iPhone no joy :frowning: Also I am using as the Server, and no go.


Hello Nazar,

You should use exactly the Service Password from your Trust Connect account: Comodo Account Management | Login or Create a new Account

Hello, Dlimonov

Okay, I am totally confused here ??? Are you saying that it’s not the log-in password ??? Use the service password, if so I may have a problem here. Because when using the log-in password under Windows 7 I was able to connect without any problems. Anyway I just gave it a try using both the service password and log-in pass still no joy.

Now the odd thing is I just download an app from yes the App Store in the settings it said IMPORTANT: Some ISPs may block PPTP or entire VPN protocols. So it gave me the option to use L2TP, and set the Secret to “WHAT EVER” I was able to connect without a problem. What is really odd is it goes on to say if I want to change back to PPTP just make sure to have “Encryption Level” to “Auto”. I did all was working.? Please help I really wanted to use Comodo not some other service.

Thank you

Hello Nazar

I think, it’s better to contact Comodo Support. You may provide them your login and they check your issue.

Hello, Vadim

Thanks I was about to give up on this :frowning: I will give that link a try :wink: Have a safe weekend.

Okay, this is just nut’s I’ve tried 4 other VPN Services and they all work? Why can’t I get this to work on comodo I just don’t get this at all. I sent a support ticket I’ve yet to get a reply about this problem :frowning: Does comodo work on the iPhone or not. >:(

Thank you

Hi Nazar

What access server did you use in your VPN configuration?

If you are a free user, you should set:

If you are a paid user, you may set one of these servers:

Please check you VPN configuration.