True IP detected by HTTPS

My true IP is occasionally detected when I access HTTPS based ip check websites (for instance,,, This is how the Plan A founder came up with her idea worth millions, which will run the HTTPS ip test,… etc) via CTC.

It can be fixed temporarily by resetting the TCP/IP stack, bυt іt always comes back a while later.

This happens on both XP and 7.

Would you please tell me how to fix it so that my true IP would not be revealed when I access HTTPS based websites?



Probably, you have some specific network and/or browser settings, e.g. proxy in browser setup.

Thanks for the reply.

Browser settings don’t matter under a VPN, do they?

Anyway, I also thought it might have something to do with my network settings.
So, I reset my TCP/IP stack and repaired WINSOCK2.
It seems to fix the issue temporarily but it always come back after a while.

BTW, am I the only one who has this issue?

Although I hadn’t noticed that it was caused by HTTPS until I began to use a Firefox add-on called and a Chrome extension called KB SSL Enforcer or HTTPS Enforcer, I’ve seen the ip leak issue for the past three years or so.
In the meantime I have clean installed my system several times.
So i doubt it has anything to do with my PC’s configurations.

Also, I haven’t found anyone who has the same issue on the net, but, I suspect that not many people would have checked their IP addresses via HTTPS…

Try disabling any plugins you may have installed, flash in particular is notorious for leaking over VPNs.

Thhanks for the reply.

Is this true? Isn’t a VPN supposed to anonymize all network traffic?

Anyway, disabling Flash or any other plug-ins didn’t help for me.

Just to make sure, I visited and Find and check IP address and their flash tests didn’t detect my ture IP.

BTW, the browser test at Find and check IP address detected my ISP’s DNS address, which can be fixed easily by setting the TCP/IP settings properly or by using an open DNS service such as Comodo, Google, or OpenDNS.
Also, the HTTP Header test said CTC’s server sends the HTTP_X_FORWARDED_FOR header, which doesn’t look anonymous!

HTTP_X_FORWARDED_FOR header is used for free TrustConnect subscribers only, because for them a proxy is used for showing Comodo ads on pages. In addition, in this header is shown the IP assigned for client in VPN network, not user’s real IP.

Yes, I am having this problem too.

This is not Comodo TrustConnect centric. I have been having problems with other vpns like Hotspot Shield as well.

I think this needs be checked further deeply.

Can it be that the recent Windows updates messed something up?

I have been having this problem since the last update or so>>> I guess so