troubles with update

i was posting in this topic: which now is marked as solved, but it is not solved. for me the update screen also freezed at 81% or something, i checked the version in info and there was already shown the new version. after waiting for a long time finally i stopped the update to get the “security agent could not be started”- error on attempting to open CIS interface. i run a diagnostic, which found some errors that could not be repaired. later i got another “security agent could not be started”- error and that time the diagnostic found no error at all! (btw how to start that diagnostic manually?)
so i rebooted the computer, then commodo was back, could be opened and the new interface was shown which i changed and after another reboot it was finally changed. the icon on the desktop however keeps reappearing after deleting it. :frowning:
is my installation now ok or corrupted? i saved those two diagnostic files.
btw i already had CIS version 10 before this update.

Still waiting for some information on these issues myself but if you want to manually launch the diagnostic. Click the (?) at the top right of the application and on the menu select > Support > Diagnostics

Same issue here. I let it try to install the update for an hour, finally shut it down. When I turned my PC on this morning I got CIS failed to start like posted in this thread

I’m running W7 and have had CIS for years now. I’m currently trying to reinstall CIS and it’s been stuck on trying to install some dragon browser (which I don’t want) for at least 10 min. Maybe its time to go back to outpost? Comodo seems to be now installing a lot of bloatware ■■■■ with no option to opt-out.

Hi Raggansta,

Thank you for feedback. This bug is already recorded.
Fix will be done soon.

Kind Regards,

hey Prem,
thanks for your answer.
is my installation now corrupted? or safe to use?

thank you Qnxunix, i run it and it didnt find any errors.

when is “soon”?
is my installation corrupted because of this installation-bug? ???

I am running Windows 10 Home 64bit version 1607 fully patched.

I updated from CFW 8.4 to latest v10 using the internal updater. The update downloaded OK but the install stopped at 81.6%. After an hour I stopped it and restarted Windows. CFW 10 appeared to start normally and said that “All systems are active and running”. Since the update, running diagnostics usually fails but sometimes succeeds. After several Windows restarts and shutdown/startups this has not changed. Running the internal updater again says that no updates are available.

CFW also appears to have lost its settings judging by the sudden flood of alerts that I am receiving since the update.

When I attempted a “change” to Comodo Firewall in Control Panel>Programs and Features it gave me an error saying Comodo Firewall couldn’t be uninstalled. The “Modify” option for Comodo Firewall in Settings>System>Apps & Features is greyed out.

So I have now joined the ever increasing number of users hit by Comodo’s unreliable updates. CFW appears to be working but it is obviously not 100% which is not a comforting scenario. I may be able to fix it with a clean install (when the offline installer is available) but first I have to rely on the unsupported CIS removal tool which doesn’t always work according to other posts on this forum.

Comodo claims that CIS is user-friendly and suitable for ordinary users. This will NEVER be true until Comodo gets their act together and makes updates reliable, streamlined and basically invisible to users who don’t have the time or expertise to fix problems like this.

i sign the previous post.

Please try uninstalling and using the removal tool based on what OS you are running from here and install again using the standalone installer. The problem stems from updating using the internal updates instead of doing a clean install.

the internal updater should work 100%… whats the use of releasing something that doesent work? i don’t feel like to again make a so called clean install just because some broken updates are released to the public… and then find the same bugs again.

Updated to Premium 10 CIS, have rebooted 4 times to get it to work. I am running Windows 7 Ultimate with all the MS updates, removed the old CIS version and Malwarebytes to install. It says it can’t install Geek Buddy, something is corrupted, then it goes on and says it installs CIS premium 10. I could get the settings to work but nothing else. I went to the original look (green) and now CIS stops working. I have started a diagnostics file, so where do I send it?

i know that page. it is very confusing and outdated. where do i get the correct removal tool for win 8.1 64 bit and where do i get the latest standalone installer for CIS please?

For Windows 8/8.1/10 use this tool and when you run it, use run as administrator context-menu. Once it is done reboot then install using the standalone install which can be found in the release topic.

[quote author=umesh link=topic=118704.msg853856#msg853856 date=1491486378]
Hi All,
We are happy to announce release of CIS v10.0.1.6209. This release is on top of last released version v6092, where in addition to other changes we introduced Secure Shopping feature.

Comodo Internet Security
Size: 5.2M ( 5363688 )
MD5: b4e7bcb144da19cdcda3868050666f60
SHA1: ced207d49b3e0f4e07e406e25c965f819ca7fbb9

Comodo Antivirus
Size: 5.2M ( 5363680 )
MD5: 8f1815fdb5cf3719344d39270145cef2
SHA1: c90f90438dfef39de0ba25e0589f4e8d55d1a30f

Comodo Firewall
Size: 5.2M ( 5363680 )
MD5: e8b7541b4ef233bdf6154e2f872d2e46
SHA1: ea7fc1179e1ef5fe17478a94bd6caad65af61b38

Offline Installer:
Based on very heavy demand of offline installer, we are exposing following web page, via which you can download CIS Premium Offline installer:

Size: 70.6 MB (74,104,832 bytes)
MD-5: 974f826b1ed31006d8cc7743a6b8ede7
SHA-1: 163cd050dfa5456abfe95e24f10796a7624afbef

thank you.
maybe i will try that if i am motivated.

Hello. I Hve the same problem. I found this page with discussion. So I did all steps in section A and its not working. Still have message “Comodo agent could not be started”. Later will try section B. Thats very sad…

Upd: I have istalled preview build v6217 and now problem is gone!;msg855735