Trouble disconnecting internet connection


After installing Comodo Personal Firewall, I’ve started having trouble disconnecting from the internet. I right-click the icon in the system tray and choose to disconnect. The connection is terminated but the icon just sits there. I am then unable to reconnect. Only a reboot sorts things out. I have since uninstalled the firewall and the problem has gone, but I really would like to use Comodo. Any ideas anyone?

System specs: WinXP SP2 (fully updated), AMD 1.2ghz, Tiscali Broadband, Firefox browser.

Thank you.

Start - Run - services.msc

Check, if you have those services started and set them to Automatic startup:

Network Connections, Remote Access Connection Manager, Telephony (for dialup, DSL, LAN).


Those services were indeed set to manual so I changed them to automatic as you suggested and then I reinstalled Comodo Personal Firewall. And now it works properly. I can now disconnect from the internet properly.

Thank you very much for your help, it is greatly appreciated.


I’m having the same problem when disconnecting from a VPN (PTTP connection) that I use occasionally to connect the internal network of my employer. I can connect to the VPN just fine, but once I disconnect all network connectivity is lost. At this point absolutely no traffic will flow out of any of the network cards (to either the internet or my local network). I tried setting the services mentioned in this thread to Automatic, but it did not help. Exiting Comodo or Setting the security level to allow all does not help either. The only thing I can do to get network connectivity back is to reboot. I’m using version Kerio PF can handle the VPN just fine, but I like Comodo more and I rather use it. Please help.

Update to my previous post:

Although setting those services to automatic seemed to work initially, I am still getting some problems disconnecting from the internet. About 50% of the time I am able to disconnect, the rest I cannot. At the moment I’ve gone back to ZoneAlarm. I like Comodo though and would like to use it. I’ve tried the latest version (and the latest beta v2.4.1.96) but the same problem persists, so please help.

The icon you’re clicking to disconnect… are you referring to your network connection icon, and that you’re disabling it, then re-enabling to reconnect?

I just took that route, on the chance that’s what you’re doing. I had no problem. Although the network icon did disappear (I would tend to think that’s an issue separate from CPF, but who knows…). But here’s something…

When I re-enabled the network, I got a CAVS HIPS popup notifying me that the network card driver was trying to connect. If I stopped it, I wasn’t allowed to connect. Allow it, and I could. This is interesting to me because I don’t get that driver alert any other time. Now that’s CAVS and not CPF, but it makes me think that something different is happening on your system when you re-enable the network, which may be blocked by some rule you have in CPF (a network rule, application rule, or component rule).

All my services are set to manual (as noted by TheTOM_SK), so I don’t think that’s the issue.

When you installed, did you choose the automatic setup? Have you changed any default rules? Did you run the Trusted Application and Trusted Network Wizards? Do you have logging turned on? If so, what do your firewall logs say at the time your connection can’t be opened/restored?

gfeiner, I really think yours may be a different issue, as it relates to VPN (although there may be some similarities). A quick search on VPN (I didn’t even look for PTTP) says you may have to set up a trusted application rule for your VPN app, define specific ports for it, etc.

The questions in blue are for both of you; it may help clarify (If CPF is blocking some connection - others have found resolution that way - then that may clear it all up). I also suggest that you search the forum (use Advanced Search to eliminate all but just Firewall-related results) for others with the same problem - if you haven’t already. If nothing else, you can file a support ticket to see what Comodo says. If you do so, please post the solution for others’ benefit.

Hope this helps point you in the right direction; I’m glad to help all I can, as are others.


PS: I’m also using Firefox (although I don’t think that’s it, either…)


Following up on this topic, I seem to be having the same problem. After installing the latest beta I notice that my connection icon no longer appears in the systray so the only way i can disconnect is to physically unplug the cable. then when i try to reconnect it seems to go thru the motions but i don’t seem to have much joy. so a reboot is needed.

Further when I place a pendrive in one of the usb port its icon no longer appears, so i can’t safely unplug that either.

whilst all the above recommendations are well and good, for someone like me who just wants to install something and get on with it, having to go into programs i never knew even existed on my machine (read services.msc), well, it’s not something I want to have to go thru. I want a program that will make my life easier, not testier.

Having said that, i like the ‘feel’ of the program and hope to continue using it despite it’s quirks in anticpation that all these issues are sorted out sooner rather than later.




You shouldn’t have to go into services; I know that as a “regular joe” user that’s not what you’re looking for in software.

I’m not sure why your network icon has disappeared, but try this -

Go to Start/Control Panel/Network Connections. Right-click your active connection, and choose Properties. On the next window that opens, under the General tab, look down toward the bottom. There are two boxes there, to be checked - “Show icon in notification area when connected,” and “Notify me when this connection has limited or no connectivity.” Make sure that the “Show icon” one is checked.

If it’s not checked, that’s perhaps an easy fix. If it is checked, we may have to dig a little deeper.

Also, please be aware that the current stable release of CPF is 2.3.6.xx; downloadable from the Comodo website, here. The Beta offerings, by default, are glitchy (read, they may make your life “testier” – :wink: ). The stable release of 2.4, per Melih, is anticipated (at this point) later this month, which will address a number of issues (possibly these as well).

BTW, I am using, and do not experience these issues (not saying that’s the only reason, but it’s possible). You may have more joy using the current stable version.

At any rate, follow the directions in red, and see if that helps. Please post back with your results.


Little Mac,

Thanks for the prompt response. Unfortunately the option to show the icon when connected is already checked. I do not have the second option as noted in your message so can’t comment on it. I don’t think this would be the cause of the problem as my removeable disk icon is also missing when I connect pen drive.

Whilst I am aware beta versions are always glitchy, one lives in hope that the glitches never affect you and your specific workflows… oh well. I’ll download the stable version to see if it resolves the problem, although I do note that this problem has been around since Oct 16 at the earliest!?! I live in hope.

Thanks again. Regards,


I was looking for another post I saw recently, but I can’t find it quickly enough. It sounds somewhat similar, that CPF Main may be locking some access (I say this because of the pendrive issue). If so, it’s a bug that Melih has stated will be resolved with the final release of v. 2.4 (which may be as soon as later this month).

If I find it I’ll post back more details.

Also, feel free to file a ticket with Support, at, and be sure to make a post in the Firewall Beta Corner for the version you’re running, in the event that it’s a different issue.


PS: Here’s the topic I was talking about, that I thought had some potential for being similar…,2304.0.html. Not sure if it is or isn’t, but in my mind there might be a connection… :THNK