Trouble connecting to Internet with Comodo on

Hi…when I have comodo on, very often I can’t connect to the internet. The wireless signal is “excellent” but the connection is poor and I can’t browse the internet. When I turn Comodo off, I can connect. No problem.

In doing a little research here, it appears that turning off “Monitor DNS Queries” in the Comodo settings can help. I tried it and sure enough that fixed it.

The question is, is it safe to keep that option permanently unchecked??? Seems to me doing so would pose a security risk.

Another question is if there is another way to deal with the issue.

Thanks in advance for your help.


Welcome to the forums LGM :slight_smile:

The best way to configure DNS is to create a couple of rules in Network Monitor.

Allow UDP OUT from (your ip or any) to (your ISP dns servers) source port 1024-4999 destination port 53.

Block UDP Out from any to any - source port any - destination port 53
Block TCP Out from any to any - source port any - destination port 53

Its not often that DNS uses TCP, but that last rule is just in case…

Put the first rule near the top amd the last two near the bottom.

Hope this helps


Thanks for your quick reply, Toggie.

I have a few questions regarding the first rule. Do you mean I can select either my IP or “any” for the source and it doesn’t matter which? Also, how do I find out what my ISP’s dns servers are?

I have Verizon DSL service and a Westell modem. Do I find it in the configuration page which I know how to get into? Also, I am not sure but I think that every time I connect I get a new IP address. So will that effect these settings? Or is the IP address different than the dns servers?

In the configuration page, there are three listings under IP Network Address – one for PPP, one for Primary DNS, and one for Secondary DNS. Do I use any or all of these numbers? As I said, I think that I get a new IP address whenever I connect. IOW, I do not have a static IP address.

There is a domain name listed in the configuration page. Would putting that in be just as effective?


Once you have connected to the Internet, do the following:

Open Start/Run and type cmd

In the command prompt window type ipconfig /all

Towards the bottom there should be two entries for DNS servers. write these down as they will be used in your rules.

In the first rule (if you don’t have a router use ‘ANY’ this just means your IP Address, as its not fixed, and will change every time you connect:

Allow UDP OUT from (ANY) to (your ISP dns servers) source port 1024-4999 destination port 53.


Toggie, I have a Westell combo wireless router/modem. Can I still put in “any” as the source?



If the IP address on your Internet connected PC changes every time you connect to the net, i.e. is assigned by your ISP, then use ANY. if you have a private network with statically assigned IP addresses, then use that address.


You can also use your computer name instead of any. Just another option when writing rules. ;D


Thanks Toggie and Jasper for your help. I have implemented the rules as specified by Toggie and it seems to have helped some but not entirely. I still can’t connect occasionally, though the incidents seem to have been cut in roughly half.

I thought maybe creating a rule with my “computer name” as Jasper suggested might help, but I didn’t see where you could put in your computer name. I did see where there was an option for “zone” and when I clicked that my wireless adapter card appeared in a dropdown box. Would that help? Is that what you meant by “computer name”?

BTW, forgot to say initially that once I do connect, I can turn Comodo back on and it doesn’t interfere with browsing. It’s just when my laptop reboots or comes out of hibernation that I can’t connect until I disable Comodo.


Does the log show anything getting blocked when you have trouble getting on the Internet?

Go to: Activity>Logs


Jasper, in the last hour I rebooted 3 times as I’ve been testing some monitor profiles that load up on startup. Twice the internet connection was made without any problems. The third time the old problem resurfaced and my laptop wouldn’t make a connection. I looked at the logs and it showed something blocked by the Network Monitor. It said:

Outbound Policy Violation, Access Denied, Protocol=IGMP

There were also some IP addresses given as the source and destination, and the reason given is Network Control Rule ID=6

I have no clue whether this information is relevant to the issue I’m having. It was the only thing I saw blocked apart from things listed under Application Monitor.

Have any clue?