Trouble Connecting at Various Hot Spots

Hello. I’m a fairly new CTC subscriber (paid version) and recently have been having trouble connecting. I get log messages such as “ERROR: could not read Auth username from stdin”, or “all TAP-32 adapters currently in use”. The product worked fine for a while but is now giving me trouble. Any ideas what may be wrong and how I can fix this? Thanks in advance…

I would recommend you contact the support (TrustConnect department) and provide logs and the Debug Info (Start → All Programs → Comodo → Comodo TrustConnect → Debug info) before and after connection.

Thanks. I’ll give that try. Is it possible that this problem could be caused by using WiFi at those locations where you have to sign in as opposed to other unsecured hot spots where no sign in is necessary?

I’ve tried reaching customer support but I can’t reach anybody. No passwords or user log-ins that I have for CTC seem to work. Here is a partial portion of the diagnostic log. Maybe you can make something out of it. Thanks for your help.


Fri Nov 30 16:20:20 2012 OpenVPN 2.1.1 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Dec 11 2009
Fri Nov 30 16:20:20 2012 ERROR: could not read Auth username from stdin
Fri Nov 30 16:20:20 2012 Exiting

“All TAP-Win32 adapters on this system are currently in use” - this error in your OpenVPN log file indicates that there are no TAP adapters available on the system for use. One cause could be that the adapter was not properly disconnected from the previous session which could be the result of a system error or an improper shutdown - leaving it in the connected state. Another possibility is that the TAP adapter has become corrupted and cannot load properly. Or, was inadvertently removed from the system.
Or, there is another openVPN client which is already using TAP adapter. Therefore firstly please make sure that you don’t have any other openVPN client running at one time with TrustConnect.

To check the status of the TAP adapter:
in Windows XP:
Go to Control Panel - Network Connections

in Windows 7:
Go to Control Panel - Network and Internet - Network and Sharing Center - Change adapter settings

-if the adapter shows connected after receiving the error, right click on the adapter and select “disable”. Then, right click again and select “enable”.

-if the TAP adapter shows “disabled”, simply right click and select “enable”.

-if the TAP adapter doesn’t present in the list, try to re-install TrustConnect. Please note that you should have administrative rights and agree when installer prompts you to install TAP adapter.

By the way, the TrustConnect client also needs to be run as administrator.

No, this problem cannot be caused by hotspot access policy.

Well, for some reason Trust Connect is working now. I didn’t do anything I’m aware of. I still appreciate the help and will make a copy of the suggestions provided on this forum. Thanks again…