Tray icon right click menu intermittently unusable [M167] [v6]

CIS6 Systray icon. Try to enable or disable firewall or behavior blocker flashes quikly and goes away making it unusable.

A. Can’t use disable firewall or disable behavior blocker from systray Icon in bottom right.

  1. What you did: It’s intermittent. I can exactly recreate the problem this way but it may happen another. I tried to launch virtual kiosk and it hung. I signed out and signed in. reset sandbox. Then tried to disable firewall or behavior blocker from systray Icon in lower right. It would flash for a second and show the screen that gives you a choice.(where you have a choice for how long) and then go away
  2. What actually happened or you actually saw: I was never able to disable the behavior blocker or firewall from the systray icon. I had to actually open cis 6 and go to advanced settings and disable them that way.
  3. What you expected to happen or see: I expected to Simply be able to run the firewall or behavior blocker off from the systray icon.
  4. How you tried to fix it & what happened: I signed out of windows 8 and signed back and reset the sand box and that didn’t fix .I did open the virtual kiosk successfully with the behavior blocker on and the firewall on. Then exited the virtual kiosk and tried again to disable the behavior blocker or firewall from the systray still wouldn’t work I rebooted. And after booting the first thing I tried was to turn off the firewall and behavior block from the systray and it worked fine. So it may be only after a hung kiosk it would appear. But I don’t think so because after using a system after a fresh reboot and not hanging a virtual kiosk or even using a virtual kiosk I was unable to disable the behavior blocker and the firewall from the comodo systray icon.I can’t pinpoint why. i discovered this bug when I discovered the ice dragon/firefox 17.01 flash plugin auto double sandbox bug. I want to disable the behavior blocker before I use ice dragon so flash works properly with webpages. but sometimes before using ice dragon and unknown or unspecific times I cannot use the syatray icon to disable the behavior blocker and have to launch cis 6 and go into advance configuration to disable the behavior blocker there before using ice explained, and of course it happens the identical way on to totally different PC’s.
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?:
    No there is nothing else running when it occurs. I did have outlook 2013 opened one time it happened.
    It happens on both PC’s with same config in both scenarios I have explained.
  6. Details & exact version of any software (except CIS) involved (with download link unless malware):
    Avast!7.0.1474 Free Av version, Superantispyware 5.6.1014
  7. Whether you can make the problem happen again, and if so exact steps to make it happen. Yes. Reboot and try to use virtual kiosk, if it hangs then try to disable firewall and behavior blocker in the systray and they won’t disable. I t definitely will happen after the virtual kiosk won’t open the other intermittent situation when it won’t work I cannot pinpoint yet
    Any other information (eg your guess regarding the cause, with reasons):NO

B. Files appended. (Please zip unless screenshots).Screenshot not available since it vanishes instantly, Killswitch Log, And Diagnostic file attched
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues):

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active process list. If accessible, required for all issues:
  2. Screenshots illustrating the bug:
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file.
  5. Crash or freeze dump file:
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version.

C. Your set-up

  1. CIS version, AV database version & configuration used: 6.0.260739.2674 Proactive
  2. a) Have you updated (without uninstall) from a previous version of CIS:NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):Defense+ Ticked enable enhanced protection, Firewall Settings, ticked block fragmented IP Traffic, ticked enable anti-ARP spoofing. Enabled Stealth Ports
  5. Defense+, Sandbox, Firewall & AV security levels: D+= SAFE, Sandbox= partially limited, Firewall = SAFE, AV = Not Installed.
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 8 x64,UAC Off, Administrator level account
  7. Other security and utility software currently installed: Superantispyware 5.6.1014, Avast!7.0.1474 Free version
  8. Other security software previously installed at any time since Windows was last installed: none
  9. Virtual machine used (Please do NOT use Virtual box):NONE, But issue occurs on two different PC”S both running Windows 8 x64 pro, UAC OFF, Administrator accounts

12-21-2012 7:30pm i clicked ice dragon and forgot to turn off behavior blocker with systray icon. quickly clicked on systray icon while ice dragon was loading up and tried to disable behavior blocker with systray icon and it it flashed for a second and went away had to open cis and go into advanced settings for defense + and turn behavior blocker off that way.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


CIS version:

OS version:
Windows 8 Pro x64

What you did:
I tried to temporary disable some modules (i.e. Behaviour Blocker).

What you actually saw:
Sometimes, the popup message that asks for the time for which keep the module disabled (15, 30, 60 minutes or permanently) appears but immediately disappears. I have to restart Windows in order to restore the correct behaviour.

What you expected to happen or see:
The popup message shouldn’t immediately disappear, so I can complete the module disabling.

This issue has been widely reported, i.e.:

I submitted a formatted bug report on this…

DrHaze… :-TU

Good. However it’s not just a tray icon issue, there is the same issue if you try to disable a module from the main form.

If i click double left click on the systray icon while this is is happening and go into advanced tasks,open advanced settings, and go to firewall settings, behavior blocker settings and hips settings i am still able to disable all three services while the systray icon doesn’t work to disable firewall or behavior blocker.Explain what you mean in more detail about main form.

You can have the same issue with the popup message if you try to disable a module from this place:

I see what you are saying never tried it that way.the default screen looks this way until(see first attached jpg) you click on the word active with the real time protection then it looks this way to me(second attached jpg).so now i see. i have never seen that screen before.

[attachment deleted by admin]

Yes, it works that way

You correct i had the systray bug again and tried to use the main screen like you did.
it would say off at the main screen. but i went into advanced settings and it was not off.
You are correct.

OK, shall I merge the reports then guys? Else I’ll have to ask you for a full report on this as a separate issue.

It’s a GUI issue, provided informations should be more than enough, however I think you can merge the threads, basically it’s the same issue, the difference is that it’s not a trayicon-related issue, as you can reproduce it from the main form too.

Thanks very much (just FYI it needs to be a pure GUI issue - no functional code involvement - for the simpler format)

Best wishes


I’ve something else to add.

The bug also appears to not be strictly related to the activation/deactivation of modules. I just had an alert (firewall message? hips message?) and it immediately disappered.

yes, same problem here.
randomly some popup appears and immediatly disappear without giving the opportunity to answer.

Another one:

Thanks for the update, much appreciated.

another one related to similar behavior.

Hi guys
It is a conflict between windows 8 shutdown mechanism and CIS. As you know hibernation and shutdown are combined by Microsoft. So there is difference between shutdown and restart in windows 8. If you shutdown your win 8 then CIS cannot be disabled and if you restart, it won’t have any problem and you can disable CIS. Actually it is a bug from CIS and should be considered.

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.