Tray icon missing... COMODO CIS - Antivirus 7.0.317799.4142

No it is not Windows XP…

Tray icon missing on Windows 8.1

  • I selected antivirus only when installing Comodo Internet Security
  • After first scan and restart tray icon is missing as well as desktop widget
  • No COMODO exe files in startup (see attached screenshot)
  • But cmdagent.exe and cavwp.exe run by the SYSTEM user visible in taks manager (see attached screenshot)
  • I uninstalled Comodo and installed once again - still the same
  • I downloaded installer once again ind reinstalled once again - still the same
  • I uninstalled Comodo, used CCleaner to clean reistry and temporary files and installed once again - still the same
  • Tray icon appears only when I run Comodo manually

please tell me how to fix this ???

[attachment deleted by admin]

I have the exact same issue. Fresh format and install of Windows 8.1 with all updates, then Comodo Personal Firewall. When Windows starts the tray icon and widget do not appear and I have no idea whether Comodo is even protecting anything! I have to manually open the app then close main window for tray icon and widget to appear. Can’t locate any solutions, may have to switch firewall software.

I also have this problem. Installed COMODO Internet Security (Anti-Virus+Firewall) just yesterday.

Me too same problem windows 8.1 64-bit,
Comodo Internet Security 7.0.317799.4142
i solved because i had backup of my scheduled tasks .
to solve this with notepad ++ or any xml editor create an empty xml file
and copy the text in red and paste inside the new xml document and save it:

<?xml version="1.0" encoding="UTF-16"?> COMODO Security Solutions Inc. true S-1-5-4 LeastPrivilege Parallel false false true true false PT10M PT1H false false true true false false false PT0S 4 C:\Program Files\COMODO\COMODO Internet Security\cistray.exe

now open from Administrative Tools ‘Task Scheduler’ and from the menu action choose import task and select the new xml document, it will ask you to give it a name , name it as you want ex: comodo trayicon and reatat your pc and it will work.

this for 64-bit version, for the 32-bit you have to change the patch inside the xml document to program files(x86).

good luck

The same happens to me.
Windows 8.1 Pro 64 bits, clean install on 2014/09/20, CIS 7.0.317799.4142.
Why Comodo have not solved this yet?

It’s a bug you need to start cistray.exe
You need to add it to startup key :slight_smile:

Same problem here. System tray icon doesn’t show up at system boot. ???

I have the same problem. Tried to install an older version and update later, but no success.
Is it a Comodo or a Microsoft bug?
As I can remember I used to have a version worked well early in 2014.

Any suggests?

You can use this fix by qmarius. It will add the start entry to Task Scheduler where it is intended to be. When CIS is on a non standard path you need to edit the xml file to match the path.