Too many events!

I had all my favorite sites allowed, then something happened, and now every time I go to a site, especially on that has flash, I have to ‘allow’ it again. It even made me allow Facebook and Twitter again. What’s up? Was this a glitch that came in with the latest update? Very annoying.

Can you tell us in more detail how you did this (screenshot)?

do you allow per site?
what is the benefit?
if you dont have an “allow INgoing” rule, your browser connects to the pages that you choose. what should happen? use the stealth port wizard setting 3 (hide me from everyone), and use exclusively OUTgoing rules. a firewall should protect you from unrequested ingoing traffic.

it seems as if YOU protect yourself from using the internet :wink: