Time Machine cannot initilalize OS information.

Hello Comodo forum.

Not sure if this will be of any help to you guys, but it took me ages to figure out and solve, and I thought it would be nice if anybody else ever ended up in the same situation.

Anyhow, the message “Time Machine cannot initialize OS information.” appeared every time I tried to install Time Machine on our laptops here, and I couldn’t for the life of me figure it out. After a lot of searching and fiddling around and reinstalls I found the problem.

In short, the problem was that the laptops were installed with GPT disks instead of MBR disks.
A way to see this was by opening “disk part” (Shift +f10 doing the windows installation) and using the command “list disk” here one would be able to see if a disk is GPT or not.
For some reason if I converted the disk to MBR before installing Windows then it would complain that Windows 7 couldn’t be installed on MBR disks while using EFI and so on.

After this I began researching how to turn the GPT disk into MBR while the disk itself was running. And after trying quite a few different programs that all claimed this was easy as pie, I found one that actually worked. The program is called “AOMEI Partition Assistant”, tho one would need to use the Professional version (I’m sure you can find it somewhere).

At any rate with this program it was quite simple to convert the GPT disk to MBR and installing “Time Machine” hereafter was a piece of cake.

It seems our main problem was caused by installing windows from a USB 3.0 device, and by doing that we got a GPT disk no matter what we did. So a better solution was to install Windows using a USB 2.0 device, and convert the disk to a MBR before installing (using diskpart to convert).