Thunderbird not picking up new certificate?

Hi All,

I recently got a Comodo email certificate, and it’s working fine for signing my emails. For some reason, though, when I email a Thunderbird client, while it shows that the message is signed, it is not picking up the public key, and when the user responds and tries to encrypt their response to me, Thunderbird gives an error “failed to find an encryption certificate for {email address}.”

I’ve been using S/MIME certificates for years (Thawte and Comodo) and I’ve never had this happen before. Before, I could always send a signed email to any client, and it would pick up the public key from that.

Anybody have an idea what’s up?

I saw link about DSPAM, but I don’t think that would apply to me, as our server is not running DSPAM, and the email signature is validating…
Here’s that link anyway:;topicseen

Any other thoughts?


So, any help on this?

Outlook appears to have no problem sending me encrypted emails. So, here’s what’s happening again in brief:

  1. Get new Comodo certificate (previously using Thawte, didn’t have any problems with that).
  2. Setup Certificate in Thunderbird, and send signed email to Joe (using Outlook) and Jane (using Thunderbird).
  3. Joe, using Outlook, can reply to my signed email with an encrypted message.
  4. Jane, using Thunderbird, gets an error when trying to send me an encrypted message that says “no certificate could be found for ”.

So… what’s going on??

This all worked fine with Thawte’s cert, so the only thing I can figure is that it has something to do with the certificate?

This is on Thunderbird and Outlook 2007 (12.0.6514.5000) SP2 MSO (12.0.6425.1000)

I’m getting the same behavior with Thunderbird v3.0 as well. In other words, it allows me to get signed emails (and it lists the signed message as having a valid signature), but it won’t let me reply encrypted…?


Have you tried to add them (the recipient), to your address book? (Usually by sending them a digitally signed message. By default Thunderbird adds an address book entry to those that you correspond to.) Thunderbird 2 and 3 work flawless for me with certificates on both Windows and on Linux (I have two certs installed on each OS)

I know that this thread is way outdated but any resolution and/or insight Josh? I’m experiencing the exact same problem described in your three posts above. I’m using TB 3.1 currently. The sender’s signed certificate is recognized, picked up, and listed under ‘People’. However, attempts to reply back using encrypt fails with certificate not found. ??? I searched the TB forums and found similar reports but no answer.


same for me, unfortunately. I’ve been using S/MIME for years (Thawte, so far) and looked into Comodo as an alternative. However, encryption for users with Comodo’s certificate (e.g., sending an e-mail to myself) does not work with Thunderbird (which used to work with Thawte’s certificates):

Even though the certificate is listed under ‘People’ in the Certificate manager, the “View Security Info” dialog opened from the “S/MIME” drop-down button in the compose window will show that no certificate has been found for the recipient entered. This is the same observation previously reported by tl and Josh.

My cert has the following uses permitted according to Thunderbird:

“Email Signer Certificate”
“Email Recipient Certificate”

I am using TB 3.0.6 on WinXP.

Since there were no real answers in this thread, I wonder whether somebody is able to encrypt with a Comodo cert in Thunderbird?

I’m able to do it (send encrypted emails to myself as I do it on a weekly basis) and have been able to do so successfully since Thunderbird 2.x. I am presently on the nightly version of Thunderbird 3.1.x.

I am having this same problem… Has anyone been able to discover a solution?

I’m running the latest Thunderbird 3 and Windows 7 Pro 64 bit.

I found a (terrible) workaround. I’m using Thunderbird 3.1.4 under OS X 10.6.4.

Assume you have an email message signed by the other party, and that the other party’s certificate is already in the “People” tab of the Certificate Manager.

First, click on and delete the person’s certificate from the Certificate Manager window. Close the window and exit Thunderbird.

Run Thunderbird again and navigate to the signed message.

Now you can encrypt a message and send it to the other party. This trick seems to work a single time. It’s obviously not very convenient, but perhaps it sheds some light on the nature of the problem.