Thunderbird hangs intermittently when downloading mail on POP3 Account

Thunderbird intermittently hangs (ie never completes) and fails to download the mail. The mail is unsigned and may or may not contain an attachment. The passwords for the Account are stored in Thunderbird with a Master Password if this helps with recreation.
When I exit Thunderbird the Thunderbird.exe process remains and requires termination.
Restart Thunderbird and it hangs again on the download.

This applies to CSE, and when downloading mail on a POP3 Account.

I believe that this was introduced with Thunderbird as I had not experienced this with and prior Thunderbird releases.

Uninstalling CSE and reboot rectifies the situation. The mail downloads without a problem.

Vista Home Premium SP1.


Hi Pero,

Can you cehck inside Thunderbird and make sure that the certificates are installed in it?

Yes they are because even when I uninstall CSE I still digitally sign all messages. I’ve just checked anyway.

Can you screenshot your thunderbird settings? It should have “sign all outgoing” unchecked as CSE does the signing for you.



Thanks for your advice.
I have un-ticked ‘Digitally Signing’ under Thunderbird. I knew that ‘Do not use Encryption’ needed to be set.

However I do not see how this affects incoming traffic. The problem I describe never occurred with releases prior to Thunderbird But since TB 2.0.021, the problem occurs with all CSE releases, and

I will report any further problem. As I said it is intermittent and I cannot see any common factor at present.


When I install a new version of CSE in a computer that has Thunderbird 2, the POP port (in Thunderbird) is changed from 110 to 111. That doesn’t make Thunderbird hang, but of course it cannot download emails.

Peroulades, does this happen to you?

That never happens in my computer, with Thunderbird 3 (beta 2).


No, my POP3 port is still set at 110 on all accounts.

Also, if that had been the case I should have seen the denied action in my firewall logs as I have Block and Log for ports other than those I specify.



We are looking into this issue now and will answer to you later.

Regards, Eugene

This has happened again.

When I say hang, I mean it tries to download the message but never completes.

The particular message was about 3.6M, it had an attachment and was a Forwarded Message.

Vista Home Premium 32 Bit

Tried an un-install (reboot) and re-install of (reboot) and the message still does not appear but rather than saying ‘Downloading 1 of 1’ it gets stuck on ‘Loading’. You can display other folders etc but if you try to Check for Updates either for Thunderbird or the Add-ons those too do not complete.

Uninstalled CSE, rebooted and the message downloaded ok.

I don’t know whether any of this helps.


Hi Peroulades!

Do you have any TB plug in installed?


I previously had some connectivity problems with running CSE and anti-spam programs. I then remembered that I had installed the certificate directly into my email program instead of doing it in explorer.

Exporting the certificate - Go to IE Internet Options. Click on “Content” tab and click on Certificates. Export the certificates (remembering to tick (remove certificate after export) an then re-install the certificate resolved the connection problems i was having.

Re-install instructions here:

hope this helps further.


Hi AlxB,

If by plug-ins, you mean TB Add-ons, then I have British English Dictionary, Contacts Sidebar, Image Zoom, Minimize to Tray + Enhancer, Text size toolbar, Update Notifier.


I have since added my mail accounts to Windows Mail with CSE installed and the e-mail that failed to download under Thunderbird had no problems in Windows Mail.

I think that proves there is no problems with the Certificates loaded in Internet Explorer which is IE8.

Just to add, the mail that caused the problem in TB was neither signed nor encrypted.


Can you send digitally signed emails in TB when CSE is not installed?

Incidentally, TB Cert install instructions here:

P.S. What AV you using?

Hi Eric,

I said earlier that I could send signed messages with CSE uninstalled.

Also, I have no problems sending/receiving encrypted and/or signed mails between my internal accounts.

I have used CIS 3.8 or 3.9 AV (+ Threatfire) throughout.


Hi Peroulades ,

Can you answer, please, next questions:

  1. What Account (Limited User or Administrator) was used for CSE installation and running.
  2. Have you configured Thunderbird manually?
  3. What domain for e-mail account was used if it is public one(,, etc.)?
  4. Can you provide the screen shot of Thunderbird settings (Tools->Account settings: Server settings, Security) before and after CSE installation?
  5. Which firewalls/antispam/antivirus software is installed on your PC.

Thanks in advance.

Regards, Eugene

Hi Bulkaeu,

Sorry I must have missed your reply.

This is still very much a problem and has led to me uninstalling CSE whenever I receive emails with attachments that will not download.

To answer your questions :
1 Installed on a Standard Account. Used on both Standard and Admin Accounts and the same problem occurs on both
2 Yes, configured manually
3 My email domains are my ISP’s
4 Thunderbird settings below
5 CIS was 3.n now 4.n. No antispam other than that within Thunderbird. Happens on all versions of TB.

The only difference of with or without CSE is that I change TB to digitally sign when CSE is not installed

Yesterday’s failure to download a mail stopped at around 4.0M the first time and 3.8M the second time I tried. Had to uninstall CSE to download the mail.

Today I tested sending from one account to another an email of 17M (encrypted and signed) and it worked without a problem.

The mails that fail to download are unsigned and unencrypted from other users. One from and another

Regards Peroulades

[attachment deleted by admin]

Out of curiosity, what SMTP port are you using? Also what “Time Out” delay is your email program set to?


SMTP is 25
Timeout is the Default for Thunderbird. If you tell me the field in about:config I’ll confirm.
Also no add-ons other than British English Dictionary.


Further information:

Just asked my brother to send two large emails ie. with attachments, unsigned and unencrypted. The first showing on his system as 9637KB. CIS Active Connections for Thunderbird rapidly goes to 9.7MB and then stops but Thunderbird using CSE does not finalize the process and the Activity Indicator keeps spinning for ever and a day.

At this point I have to uninstall CSE in order to retrieve the email.