Thunderbird: can't send mails with attachments

Hi all, not a lot of time ago, I started using Thunderbird for my mails. I’ve a account and after creating it without problem, I can send mails without attachments. When I try sending an email with one or more attachments (I’m trying sending an image, about 84kb, really small) I’ve a problem look this:

The message can’t be sent because the connection at SMTP is failed. The server may not be accessible or it may refuse SMTP connections. Review outgoing server (SMTP) settings and retry, or contact the own system admin

I’ve asked to TB forums but we didn’t find a solution and they told me to ask here. I’m using COMODO Firewall and I’ve put ThunderBird to the exceptions…why have I this problem?
Some infos

*My TB version is the (20081105)
*The OS is Vista Home Premium 32bit (SP1 with all updates)
*I’m using Comodo Firewall and I’ve too tried sending the mail disabling the firewall but nothing: the same error
*My server settings, including server name and port number
Description: Gmail
Server Name:
Port: 587 (default 25)

Strange, at first everything looks ok.

Did you try to disable D+ also before sending ? it could be that TB is blocked access to the image or so.

I don’t see a reason for it in the firewall, it allows the traffic, it does not inspect what’s in the packets so the Firewall could not be the cause here.

Did you check the firewall and D+ logfiles to see if it records anything there ?

how about sending it directly via
just to make sure if it’s Comodo or thunderbird or Gmail issue.
i know Gmail won’t allow you send executable attachment (.exe/.bat) but image ???

You could try making the file encrypted, Pretty sure that it works. (I use Gmail and Thunderbird)

yeah i know that 88) i was the one who told you to use winRAR ;D
maybe it’s not CIS issue at all ??? errr this is not a good idea, but maybe try uninstalling CIS & see if the email works? 88)

Nooo!! It’s nothing to do with CIS. Gmail is jut makes it harder to transfer files (Y)

I’ve too tried disabling COMODO but nothing…