There is a problem with the encryption substation

My new external hard drive will not formatt, it tells me the drive is read only.
Because it is not formatted it does not show up in the Comodo software so I can remove the encryption.
It states on the botton of the page that " There is a problem with the encryption subsystem".
Cab anyone help me please?


Please explain with more details. If “There is a problem with the encryption subsystem” message appears at the bottom of the page this mean the authentication was not performed. Please make sure that you have typed the correct password at boot time.

I just bought the drive and decided to encrypt my data.
I installed Comodo software and then run my backup software.
It was going to take over 20 hours to backup, so I decided to quit and remove the Comodo software.
Well it looks like I failed to remove the encryption software from the drive, and after I tried to re formatted the drive, I am stuck as the drive is write protected, and I can not formate it, and seeing that it is not formatted it does not show up in the Cormodo program so I can remove the encryption software.
Is it posible to remove the write only protection so I can reformat the drive?


I still do not understand your scenario. Please tell me if am I correct.

  1. You have installed COMODO Disk Encryption.
  2. You have encrypted your external drive(the encryption process was finished with success?).
  3. You have tried to backup your data from external drive.
  4. How have you canceled the backup operation? The encryption process was still running?

I need these information in order to investigate your problem.

Thanks for the help, but I have heard from Western Digital and they told me to RMA it back to them.
Thanks again