"The network firewall is not functioning properly!"

This is how it looks after I’ve installed and restarted.

I opened the client and saw this:

I run the diagnostic and see this:

I use Windows 7 Beta (the official build 7000). It has worked fine ever since the betas release, perhaps an update did something to the network firewall?

I have reinstalled Windows 7 and I get the same thing everytime. I installed Windows Vista again on the same machine and COMODO ran fine. But I tierd of Vista and went back to 7. I really like COMODO so I’d figure I ask you guys, this is probably a simple problem.

Welcome to the Forum, Regal.
Did you run the install in Vista compatibility mode? Also, CIS (and CFPupdat.exe) needs to run in compatibility mode also.

Oh right I forgot the compatibility mode, I’ll try that shortly.

I got the same problem only in my case its on windows Xp 64 bit . Any sudgestions, ideas? P.S It wont even work in safe mode, and when i run diagnostics it says it found some erors and will try to fix it. I let it, security mesage pop ups few times saying application havent been windows logo approved would i like to continue. I press yes, it repairs itself, but then when i restart windows it never finish loading, get stuck on black screen , so have to restart and use "Last know good setings that worked " option.

Thank you Buchanan for the reminder. Comodo now works fine again.

kazys, I’m not sure but we evidently have somewhat different problems. First off, at the COMODO site where the client is downloaded there is a default option to download the 32bit client. Make sure you got the 64bit one. Perhaps after that, go to the install/uninstall icon in the control panel and repair.
COMODO seems to require XP service pack 2 or later, do you automatically download the Windows Updates? It would be interesting to hear if it was working previously and then at some point stopped working, or did you have this problem from the beginning?

No i didnt have this problem before, as i freshly instaled 64 bit windows, with all latest updates, and yes i downloaded 64bit version, but it dosent seem to work.

I use Vista x64, and the GF’s laptop is XP x32. Are you running any other AV on your system?