The mouse or mouse buttons do not work in the game.

If I run games in a container the mouse doesn’t work. Buttons do not work in some games. In other FPS, you cannot look around, but in the game menu everything works well. How to fix it ??? Previously, all games worked correctly!

Can you tell in which games the mouse and/or mouse buttons don’t work when you run those games in the container?

Also, which CIS version and which Windows version do you use?

CIS last/win 10x64
All games have problems. None of them can look around with a mouse.
Space Engineers
Recent games, but there are a lot of them.
Until the fall, I had Windows 7 and the old version of the CIS. All games worked fine.
What a nonsense! Why do we need such a sandbox if it is impossible to use programs ?!

I think that most regular programs do run in containment without issues but I agree that there are some programs which have troubles running in containment or maybe not run at all.
There is room for improvement, I would say.

Maybe somewhere there is a hidden setting not to block / filter the mouse in SB???

Not that I’m aware of. :slight_smile:

Not that much help but on my end I can play the standard Windows 7 games (such as Solitaire or Chess) with my mouse in containment.

And who, then, can help me here? This is the Comodo site, where are the developers?

Do you use a mouse that its own software that runs in the background with Windows? Can you check the HIPS logs to see if there are clues there?

No. An ordinary mouse. I’ve tried two different ones. I have no programs for them. This is all very strange. For example, in Satisfactory, I can move in the menu, select objects, but I cannot look around. :-TD

Is there a simple small shareware game (I do not like to install too many Gbytes) that I could test on my end that has this problem?

Do the HIPS logs give us a clue?

simple small shareware game
I don't even know, try any 3D game where you need to look with a mouse. Now all games take up a lot of space.
HIPS logs
I have HIPS turned off.

I tried Quake II RTX. This is a small free demo version in Steam. The menu works, but you can’t watch it in the game with mouse. Try it if you like.

It seems it requires a NVIDIA GeForce RTX 2060 (or higher) graphics card which I don’t have. So I can’t test it I’m afraid.

No, my 1660

I tried it with older onboard graphics but the game won’t start. I can’t test it. :-\

Sorry but the sandbox is not meant to be used like a virtual machine, it is used to protect the system when running unknown applications, and it is not designed to work with video games. If you enable the HIPS and then run the games in question in containment, you will see the blocked events of direct keyboard access and install global hooks of directinput.dll. The containment blocks many forms of keylogging and simulated mouse/keyboard input, hence why applications that use raw input or other forms of capturing the mouse/keyboard will not work.