The firewall is not functioning properly (also, World of Warcraft Woes)

Alright, well the firewall isn’t working. I cannot understand why. I’ve run diagnostics, and I’ve tried multiple settings, but it still will not work. When I run diagnostics, it says everything is working fine, but the firewall is still unresponsive.

I’m fairly newbish with this kind of stuff, but perfectly willing to learn. I just really need to know what’s happening, because I’m usually running on an unsecured WIFI network at my university.

Also, just so I’m not double posting and creating an unneccessary amount of threads, I have another problem (which may just pertain to the first). When trying to download the latest World of Warcraft patch (not 3.0.8, but the update that came a few days later), the tracker does not respond and it says the firewall is blocking it (which doesn’t make sense if the wall isn’t even working). Any ideas?

Welcome. :slight_smile:
Could you please provide more information about your problem. What do you mean by “unresponsive” and how do you know the firewall is not working correctly?


Well, it flat out tells me it isn’t working.

[b]System Status

The network firewall is not functioning properly!

Please run the diagnostics utility to fix the problem.[/b]

Only, when I run diagnostics it says everything is perfectly fine. I’m quite befuddled.

Please check out this thread about WoW problems and possible fixes:;msg241392 .

Try an uninstall (use a good registry cleaner after) and reinstall latest version.