The Defense+ is not functioning properly!

Hey guys, I’m a newbie here… just downloaded Comodo Internet Security (CIS) Free… I’ve installed the program a while ago but after the successful install the “COMODO Internet Security” main window displays that “The Defense+ is not functioning properly!”… I tried to restart the PC but it still says the same problem…

I am running Windows XP Pro SP 2, 32 bit.

[attachment deleted by admin]

Run the Diagnostics utility what is clearly suggested on your screenshot. You will find it in MISCELLANEOUS tab.

I seem to be having a similar issue, restarted comp, and used the “Diagnostics” prior to even comming here to look for the answer, it states it could find nothing wrong with my installation, yet it does not work… :-X

any ideas?

When the Diagnotics doesn’t fix try unisntalling Comodo using Revo Unisntaller. Use the advanced mode of Revo. Then install Comodo again.

I would try clean installation but if you’re not willing to do that you can always generate a detailed report about your configuration using this script. This might help pinpoint the issue on your system.

aight, i did a clean install when i upgraded to the new internet security bundle…and used revo to do it…i’ll give another go, and see if that works…if not, i’ll post using the scripit…thanks for the help…

Although the Defense+ is not functioning properly i still got the power of COMODO Firewall… gotta love!! Some users report that the Defense+ is somewhat annoying because it produces continual pop-ups so I decided not to install the Defense+ anymore by choosing it from the installation… It’s not a security reduction for COMODO Firewall as long as you have the “FAA” combo… “Firewall, Antivirus, Anti-spyware”

I have COMODO Firewall Pro for my firewall, Avira Antivir Personal for my antivirus, and SUPERAntiSpyware as my antispyware app…

This combo would make your computer secure enough…+

I doubt that. In these days HIPS is a crucial part of PC’s security. Just download the newest Comodo’s leaktest and see for yourself how secure you are with standard security solutions.

did another clean instal, after uninstalling I did a reg clean using comodo reg cleaner…and re-installed, update, scanned, and I am happy to report everything is green…

Thanks for the advise!

the thread is quite old, but the solution is easy.
On defrnce+ at advanced you have Settings
Deactivate the Defence+ permanently
Now activate this setting again
and restart your PC again

Hello, I have the same problem…how i can fix it? ???

Start with running Diagnostics. It is under Misceallaneous/More. Does that fix it or does the problem persist?

It does this with me on boot-up fairly often, the dignostics tool never detects anything. I exit the program, restart the program, and it apparently “fixes” itself. ???

Hi I have the same problem Defense + isn’t working. This happened after installation of “daemon tools”, in fact after install of daemon tools firewall of Comodo Internet Securiry 3.13.121240.574 version stopped working. I did everything I could to fix the problem I uninstalled daemon tools using revo uninstaller I uninstalled comodo using the same tool and reinstalled only comodo but the problem persists. I downloaded latest version of Comodo but here Defense + isn’t working. I read the forum and I tried every solution I thought of but nothing worked out. I even used system restore but that didn’t work either. Can somebody help me out please :cry:

When you uninstall Daemon Tools you don’t uninstall the SPTD driver it uses. The answer to how to uninstall the SPTD driver can be found in Daemon Tools Faq:

To remove SPTD, simply download SPTD setup file “SPTDinst-v162-x86.exe” for Windows 2000/XP/2003/Vista (32-bit) [880,624 bytes] and execute it.

In dialog that appears press “Uninstall” button and then SPTD will remove itself from your Windows installation.

If you want to install it again then execute the same setup file and press “Install”.

Then try installing CIS again. Notice that the latest version of CIS is 3.14 and that also v4 was released.

I tried everything possible but still Defense + is still not functioning properly. I uninstalled sptd from the utility setup and I even uninstalled the driver from non-plug’n’play devices because it was still in there. I uninstalled COMODO v.4 and installed it again … but nothing is different now. Anyone any ideas?

Following is a tutorial to look up left behind drivers of previously installed security program. Does that help here?

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

In case you want to do a clean install of CIS use this clean up tool.