Terrible problems with CIS since upgrading to Win 10


I’ve been running CIS for years with no problems. I love it!

I 'm currently running version

I upgraded to Windows 10 two weeks ago, and immediately began having problems.

First, Google Chrome (my default browser) wouldn’t open.

I finally resolved that when I came on here and saw the video on your fix, and applied it.

Problems persisted, though. When I open a new browser window, or a new tab, the window doesn’t come up for a few seconds. When it does, you can see the address bar, but the rest of the page remains white for a few seconds, to a few minutes. Once you can see the page, it is frozen. Anytime you go to type an address into the address bar, it highlights the old address, but the new one doesn’t show up for between 10, and 30 seconds; sometimes very slowly, just one character at a time.

The longer the computer is running, and/or the more tabs that are open, the worse this gets. Edge is the slowest of all, then Chrome, Then Firefox. Maxthon isn’t that badly affected.

I’ve run Comodo Cleaning Essentials, CCleaner, MalwareBytes, ESET, and a host of other anti-malware tools as the guys on the PC Help Forum and the Techspot forum have tried to help me with this.

Today, I had four tabs running in Chrome since this morning, and it has gotten steadily slower, and slower, until it took over 3 minutes from the time I clicked on a tab until I was able to access the page, and it would freeze again as soon as I took any action.

I noticed the hard drive was whining like crazy, so I opened the task manager, and went to performance.

The Disk was at 100%, and stayed there, never dipping below 95%.

The biggest resource hog was cavwp.exe. I searched it, and it is a Comodo Internet Security file associated with scheduled scans. I’ve had no scan running today.

I restarted the computer, and now Disk hovers between 0, and 3%. If it runs true to form, that number will go up the longer I run the computer, until, in a few hours, it’s back where it was.

Even with the disk use hovering at 3%, and cavwp.exe not even showing up in Processes, the internet is still dragging.

Can anyone help?


Did you try a clean install of CIS in the process? That is the first thing to consider after making a big migration like upgrading. Do you have other security programs installed and which one(s) runs alongside CIS in the background?

Can you check if a scheduled scan or cache builder/cache cleaner was running by looking at the Taks Log? Cavwp.exe is responsible for all av scanning; on access scanning, scheduled or user requested system scan and I also think the cache builder/cache cleaner tasks.