System Restore doesn't work

Can you Please fix it so that Comodo will allow system restore to work?
I am running comodo firewall 5.10, and tried to do a system restore because my graphics driver was not working, and i got an error saying that something was blocking system restore, and it could not be compleated sucessfulley.

I agree wholeheartedly.

By the time you reach for Windows System Restore things are generally desperate. The very last thing you need is to be told “no you can’t fix your problem because Comodo is preventing it”.

What happens is that System Restore tried to restore the Comodo Quarantine folder along with everything else. But Comodo doesn’t allow the restore tool to touch it. So the whole system restore is unwound at the last moment.

Comodo, you need either to allow the Windows System Restore tool to restore old versions of the Quarantine contents, or else hide them from the System backup process in the first place and prevent System Restore from even trying to overwrite it. You have really dropped the ball here. This is absolutely basic stuff.

Does this only happen if you’re using the antivirus? What if it is empty?

If you, or anyone, would like a wish such as this to be considered please create a new wish for this. The required format is provided here and an explanation of how the Wish Board now works is provided in this topic.

Let me know if you have any questions.