"System" process using 60%+ CPU usage with Comodo enabled...

Hi all.

I am a big fan of Comodo firewall and have been using it for about 12 months now and love it. However, I recently reinstalled Windows XP, installed the latest version and have noticed a problem.

Basically, “System” in my processes sometimes uses 60-100% CPU usage. It happeneds a few times everyday and is very annoying, especially when playing games, etc.

So I decided to try and find out what was causing it, and I graducally ended processes of things that I thought might be causing. As soon as I disabled Comodo, my CPU usage immediately dropped to 2%…
I have now tried this for the last 7 days and I am almost certain Comodo is causing this “System” process to use massive amounts of CPU usage for no reason.

Just to make this clear, my PC is very high spec (Intel core 2 duo 2.2Ghz dualcore, 4GB RAM, 100GB 7200RPM HHD, etc). It is a clean install, has no viruses, spyware, etc. My CPU usage is very low all the time, except for when “System” suddenly spikes. I have tried it about 10 times now, and every single time when I disable Comodo it drops back to normal.

I have others have had this problem by searching google (this is how I found this forum).
I will need to uninstall it if I can’t find a fix and I don’t want to do that!

Does anyone know why this is happening?


This may be due to your logging file. Have a Look at Activity > Logs.

Right now I am logging a couple of “random” Input Policy Violations every minute. No problem

Some weeks ago my cooling fan went turbo charged, and I found 100% CPU usage on a 5 second cycle. I eventually found my log was showing that a vast zombie army had been given my IP Address, and every 5 seconds a fresh squad of a dozen or so would storm my gates. The Firewall held OK but the log file activity hit the CPU hard - it just kept on until I disconnected and re-dialled and my ISP gave me a new dynamic IP Address and the Zombies lost touch.

If the logging file is your problem, there is at least one thread in this forum I came across a month ago which deals with this.


Thanks Alan,

I just checked the logs and they were absolutely full with Policy violations - all from my local network.
I don’t think I configured the firewall to allow my network correctly because I could never use my printer (which is attached to my other PC on the network) without disabling Comodo.
Anyway, I just went to “Security” then “Define a new trusted network” and added my local area network, and so far the policy violations have stopped and I can now use my network printer with Comodo enabled.

Hopefully this has fixed the problem.

Many thanks for you’re help.



You are welcome.

I am glad it was an innocent problem you could easily fix, and not a hacker playing internet games with you !!!