System failure after comodo install.

Hi, I really liked COMODO so I’m trying to get this done right.

Yes of course I’m having installation problems ( Error: 1603 ) so i run clean up tool, (from: and it worked for me. Or at least I thought it worked.

The problem is, that after restart, i cannot log in to windows, i just got black screen and mouse working, nothing more. And i cannot do anything more than hard reset and run system restore. I tried also manually removing anything from previous comodo installation, but no effect.

So, does anyone have similar problem? Any solutions maybe? Or should i just give up COMODO and find something else?

Hi, I’m also having big trouble after installing comodo v4.

Installation went ok, but after restart → explore crash and after that dr watson crash. computer frozed like that every time I restarted.

tried to uninstall comodo v4 in safe mode. It didn’t work.
finally I had to restore system few days back.

updated windows installer to v 4.5 → didn’t help.

Any ideas??

The clean-up script finishes of by deleting the repository so that Windows can rebuild it after a reboot.
The reason is that Windows has its own special junk in the repository, from which Windows Security may decide that you still have the old and removed security protection, and Windows Security will absolutely block any new and (in its mind) “additional” security protection.

After I ran it I observed that the System Error Log showed that it failed to rebuild 4 off .NET framework components.
Further reboots did not repeat the error message so I assumed they had been successful.

I now understand that there were no further rebuild attempts, so my .NET framework remains crippled to some unknown extent.

After many hours activity in many technical forums over many months I now believe :-
The repository should NEVER be deleted;
You should not meddle with it if Windows Security console considers that Comodo is absent;
If Windows Security has got it wrong then as a last resort the repository should be renamed, then you have a fall back recovery position where needed;
There are potentially better and safer ways around Windows Security than rebuilding the repository.
Under My Computer / Manage / Services and Applications / WMI Control / Properties
there are buttons for “Backup now” and “restore now”

There is advice on the Microsoft site that Windows may have some unknown damage that will cripple its ability to rebuild a repository with dire consequences. What they are I do not know, but I guess a perpetual BSOD is always on the cards ! ! !

I wish I knew all of the above before I ran the script last year ! !

Just possibly you both are victims of Windows that had suffered too many Patch Tuesdays and lost its ability to rebuild the repository.

I posted a cleanup script that PERMITS the repository to be rebuilt if you insist. My post #31 in

My script will not mend a broken repository, but it gives you a way to clean up without damaging it.