system crashes when connecting wireless adaptor with Comodo 3 FINAL

I think i posted this in the wrong place ANOTHERONE,i have posted this in the "BSOD’S …please add your minidump here"area,Please delete THIS post as it is on the forums again,i tried to delete it but couldnt.Sorry for the trouble.

I have the m2n32-sli deluxe wireless MBoard with the realtek rtl8187 wireless 802.11g 54 Mbps usb 2.0 network adaptor,with the wireless able to run in windows zero config or in the MBoard supplied ASUS WIFI-AP SOLO(which takes control of the windows zero config).
I have tried different versions of the wireless network adaptor drivers with different versions of comodo firewall and everything i have tried has resulted in a bluescreen error and shut down of my pc during the wireless detection and enable process after doing a fresh install.
I also get the bluescreen when the wireless is being initialized after i have it all installed.
If i install comodo firewall on a fresh system it installs fine and works great,right up to the time my wireless kicks in and starts,then its bluescreen again.
If i install my wireless and get it all setup and working on a fresh install then install comodo firewall i get a bluescreen and shut down during the kernal install of comodo firewall.the last 3 versions of comodo were tested along with the latest version.
I have installed The comodo software on my system with windows xp pro x64 and x86,windows xp home x86 and x64,Vista business edition x86 and vista ultimate x64 and have the same problem on all of the operating systems tested with comodo and my wireless adaptor.I have tinkered with this MBoard and Comodo for 2 weeks or so,installed my apps in different orders after doing fresh installs,I have installed comodo after getting my windows updates and before doing them as well,before and after other software i use.
The only time i have the bluescreen is when i have comodo installed and working and my wireless adaptor tries to start(initialize) ,or i have my wireless adaptor in and working correctly and then try to install comodo(the BLUESCREEN and shut down ALWAYS occurs during the kernal install).
I can install and run comodo and my wireless and both of them work great,JUST NOT TOGETHER at the same time,and i cant install comodo after i install my wireless adaptor.
My bluescreen error says: IRQL_NOT_LESS_THAN_OR_EQUAL
and tells me to remove any newly install software(which would be comodo or my wireless adaptor),the most common cause of this error is misbehaving drivers.

My System:
ASUS m2n32-sli wireless deluxe mboard
amd 64 athlon x2
2 gig sli ready mem
nvidia geforce 8800 gt alpha dog edition
asus wifi-ap solo wireless
realtek wireless rtl 8187 adaptor
3-320g sata harddrives(not on raid setup)
benq dvd player
liteon dvd burner
verbatim cd burner
hp external dvd/lightscribe burner
epson stylus c84 printer
usb mic
belkin 4 port hub
logitech 5.1 true surround system
usb scanner
belkin nostromo n52 speedpad
netgear rangemax wireless router

I didnt install in safe mode,I tinkered with my wireless adaptor in safe mode tho.
Didnt matter what i did or how i did it,Comodo firewall will not run on my pc at any time if i use my built in wireless adaptor to connect at the same time comodo is running or installed.Comodo will run on my system if i disable my wireless adaptor and dont use it.

I havent got any esata connected drives…
I use acronis for easy restore feature to a fresh installed image when i get my tinkering done,if the log file will be of any help i can restore back and reinstall comodo to get the .dmp file for ya and then post it.ill restore tomorrow after work and get it posted…
As far as firewalls go in windows xp x64 there arent very many of them that allow total user control over what apps connect to the internet(im sure there are some of us out there that dont want certain apps to connect to the internet!!),and outpost is the one with the best features and controls until i can get my comodo back in and working right…This outpost firewall im using is a result of several weeks of testing various firewalls and coming to the realization that comodo wasnt gonna work right now,so it is a temporary thing for me.
Symantec Endpoint Protection provided good protection but the firewall doesnt work right in x64 windows xp,and i couldnt connect thru the wireless until i disabled the firewall.For some reason they built the software for administrators systems and it doesnt have CLIENT protection and configurability any more…
I did use the ghost firewall for a minute and took it out when i couldnt figure individual program access.
Zone alarm is 1 that i didnt test this time around,i did some beta testing on it some yrs back and didnt like it so i havent put it back in.
This outpost is okay for now,give it a fair shake b4 you guys condemn it altogether,at least it works with everything and has some good features…It is good for a TEMPORARY fix till we get comodo working even if i cant update it.
Kaspersky wasnt too bad,nod32 was good but you have to pay a yearly price,and symantec client security doesnt support x64 systems…
You shouldnt go out and buy a firewall right now or pay for a subscription to 1.Im sure Comodo will be fixed very soon to work with our hardware.I know the people at comodo are working on it and i am tinkering with it at home and doing a lot of reading.Hopefully it will help when i get my logfile to them and they will know where we need to start working to get it fixed.

[attachment deleted by admin]